Hybrid (Optimus) GPU laptop hangups with nvidia & hybrid mode

Hello everyone,
I’m running manjaro on my XPS 15 which has hybrid GPU. I recently managed to get it all setup and running using optimus-manager but after a while running in hybrid (or nvidia) mode (using Intel GPU as default, while allowing to use the Nvidia GPU for prime offloading) my system runs into problems when waking up from sleep. I use hybrid-sleep to ensure that if the laptop runs out of power, I can still restore it’s state. How ever in the hybrid (and also nvidia) mode, when I wake the system up it restores the screen (I can see what ever was on the screen before it went to sleep) and the system hangs. There’s no cursor, it doesn’t respond to any keys except the power button. Leaving it for a bit just makes the fans ramp up and pressing the power button causes the screen to turn off while the fans go on for a minute or two before the system shuts down. This does not happen when running the Intel GPU only.

I went through my journalctl -b1 after rebooting and found this:

Jun 16 20:04:21 malus kernel: EXT4-fs (nvme0n1p1): Cannot change data mode on remount
Jun 16 20:04:21 malus systemd-remount-fs[1143]: mount: /: mount point not mounted or bad option.
Jun 16 20:04:21 malus systemd-remount-fs[1142]: /usr/bin/mount for / exited with exit status 32.
Jun 16 20:04:21 malus systemd[1]: systemd-remount-fs.service: Main process exited, code=exited, status=1/FAILURE
Jun 16 20:04:21 malus systemd[1]: systemd-remount-fs.service: Failed with result 'exit-code'.
Jun 16 20:04:21 malus systemd[1]: Failed to start Remount Root and Kernel File Systems.

But I have no idea what could cause this, as in Intel mode this doesn’t occur.

My /etc/fstab

# /dev/nvme0n1p1
UUID=d644015d-5a28-4acf-a7ba-bd1ff57caa41	/         	ext4      	rw,noatime,nodioread_nolock,discard,nodelalloc	0 0

# /dev/nvme0n1p2
UUID=f4282f9f-b17e-4e09-b5a7-022b5e11386e	/home     	ext4      	rw,noatime,nodioread_nolock,discard,nodelalloc,data=journal	0 0

# /dev/nvme0n1p3
UUID=E8F2-7D8F      	/boot/efi 	vfat      	rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro	0 0

UUID=ae60b0ca-ff24-4111-8d97-3f7a0875e5c4	none     	swap      	defaults	0 0

My optimus-manager.conf had these options (only wrote down the ones I think matter)


Current kernel: 5.9.16-1-MANJARO (linux59)
Installed nvidia drivers:

lib32-nvidia-utils 460.39-1
linux59-nvidia 460.39-1
nvidia-utils 460.39-1

Not running any DE, installed via Manjaro architect, running sddm with Xorg & dwm.

I’m not sure what other information might be of use.

Try enabling nvidia-suspend and nvidia-resume services. And updating to the latest Nvidia driver (this involves switching to unstable branch though).

I tried to enable those services, but sadly that didn’t seem to help. I don’t really want to switch to unstable so I guess I’ll just have to deal with this.