Hybrid graphics selection not working

Currently running Civilization 5 on steam with proton (Windows version). I’m launching it without any arguments which means it should default to integrated graphics but for some reason it’s launching with the dedicated Nvidia GPU. When using specific arguments in steam or launching steam with the same arguments to force the use of the integrated graphics, Civ 5 still launches with the Nvidia card. Is there any reason why it could be doing this?

so prime-run or DRI_PRIME=1 isnt present for launch of steam or the game launch options?

Does the system behave normally otherwise?

glxinfo | grep 'renderer string'
prime-run glxinfo | grep 'renderer string'

Maybe also provide general system info too

prime-run and DRI_PRIME=1 are not used at all. The system does behave normally, nvidia-smi shows no other processes using the GPU.

Host: Razer Blade Stealth 13
Kernel: 6.1.21-1-MANJARO
DE: Plasma 5.27.3
CPU: i7-1065G7
GPU: Intel Iris Plus Graphics G7
GPU2: GeForce GTX 1650 Ti Mobile

I have the video-hybrid-intel-nvidia-prime drivers.

I made a similar post on reddit, someone suggested that DXVK disabled integrated GPU’s from the list of possible graphics devices to select? Is this true?

Try setting this as a steam launch option


Edit nevermind, I read that too quickly and I thought you were having the opposite problem.

Currently the only “fix” I’ve been able to do is just using optimus-manager and switching to exclusive integrated graphics mode on the system