Hundreds of Non-English fonts keep coming back - making LibreOffice apps a living hell

Choosing fonts on any application becomes a nerve racking job. I can’t pick a font on LibreOffice apps without going up and down a dozen times to find my font.

I have deleted non-English fonts so many times but they just keep coming back with every single OS update.

Why aren’t these fonts part of some language pack or allow users who need them to explicitly install those fonts.

Is there an easy way uninstall all non-english fonts? Because uninstalling these fonts one by one is also nerve racking job.

Install noto-fonts-lite from the AUR.

pamac build noto-fonts-lite

1 Like

Some of them can be uninstalled, but you can also use the Font Manager to disable fonts you don’t want to appear in the font lists of your applications. You can also create a fontconfig file. The latter option is probably best, because there are other fonts that show multiple languages than Noto, though it’s the biggest offender. Follow the directions here, though it is on EndeavourOS website, it works the same way on Manjaro. Tip: Managing fonts - General system - EndeavourOS


@mithrial does noto-fonts-lite replace all the other Noto fonts when you install it?

May be an answer here : [SOLVED] How to uninstall some of noto-fonts? / Applications & Desktop Environments / Arch Linux Forums , post #9

1 Like

So here is my advice, based on trying various workarounds to remove all the hundreds of other than English language fonts:

  1. Install noto-fonts-lite from the AUR. This will remove all the other Noto fonts by default.
  2. From Pamac gui remove: adobe-source-han*, ttf-droid, and ttf-indoc-otf, and any other fonts that are for languages you don’t need.

Reboot and enjoy only the English language fonts on your system.


Yes, it does.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.