Hulu Cannot Determine Location on either Firefox or Chromium Browsers

Even after giving the site location services on both Chromium and Firefox, it gives an error saying “We are unable to determine your location”. I reinstalled both, and they still error out. I’ve even tried using ElectronPlayer, and that gave me the same result upon giving location services.

If it serves any significance, my inxi -Fazy:

  Kernel: 5.16.2-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.16-x86_64
    root=UUID=993e126e-a9f3-471a-930b-53026a314373 rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: HP product: HP Pavilion Gaming Laptop 15-cx0xxx
    v: Type1ProductConfigId serial: <superuser required> Chassis: type: 10
    serial: <superuser required>
  Mobo: HP model: 8478 v: 70.60 serial: <superuser required> UEFI: Insyde
    v: F.26 date: 08/10/2021
  Info: model: Intel Core i5-8300H bits: 64 type: MT MCP arch: Coffee Lake
    family: 6 model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xEA
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 900 min/max: 800/4000 scaling: driver: intel_pstate
    governor: powersave cores: 1: 900 2: 900 3: 900 4: 900 5: 900 6: 900 7: 900
    8: 900 bogomips: 36812
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Hewlett-Packard
    driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:3e9b class-ID: 0300
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile]
    vendor: Hewlett-Packard driver: nvidia v: 495.46
    alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1c8c
    class-ID: 0300
  Device-3: Logitech HD Pro Webcam C920 type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 1-3.1:8 chip-ID: 046d:082d
    class-ID: 0102 serial: <filter>
  Device-4: AVerMedia Live Gamer MINI type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 1-3.2:11 chip-ID: 07ca:3311
    class-ID: 0102 serial: <filter>
  Device-5: Quanta HP Wide Vision HD Camera type: USB driver: uvcvideo
    bus-ID: 1-5:7 chip-ID: 0408:5300 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org compositor: kwin_x11 driver:
    loaded: modesetting,nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x1080 s-dpi: 101 s-size: 965x271mm (38.0x10.7")
    s-diag: 1002mm (39.5")
  Monitor-1: HDMI-0 res: 1920x1080 hz: 75 dpi: 102
    size: 476x268mm (18.7x10.6") diag: 546mm (21.5")
  Monitor-2: eDP-1-1 res: 1920x1080 hz: 60 dpi: 142
    size: 344x193mm (13.5x7.6") diag: 394mm (15.5")
  OpenGL: renderer: NVIDIA GeForce GTX 1050 Ti/PCIe/SSE2
    v: 4.6.0 NVIDIA 495.46 direct render: Yes
  Device-1: Intel Cannon Lake PCH cAVS vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl
    bus-ID: 00:1f.3 chip-ID: 8086:a348 class-ID: 0403
  Device-2: NVIDIA GP107GL High Definition Audio driver: snd_hda_intel
    v: kernel bus-ID: 01:00.1 chip-ID: 10de:0fb9 class-ID: 0403
  Device-3: Logitech HD Pro Webcam C920 type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 1-3.1:8 chip-ID: 046d:082d
    class-ID: 0102 serial: <filter>
  Device-4: AVerMedia Live Gamer MINI type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 1-3.2:11 chip-ID: 07ca:3311
    class-ID: 0102 serial: <filter>
  Device-5: JMTek LLC. USB PnP Audio Device type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-3.3:12 chip-ID: 0c76:161e
    class-ID: 0300
  Sound Server-1: ALSA v: k5.16.2-1-MANJARO running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: JACK v: 1.9.20 running: no
  Sound Server-4: PulseAudio v: 15.0 running: yes
  Sound Server-5: PipeWire v: 0.3.43 running: no
  Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:a370 class-ID: 0280
  IF: wlo1 state: down mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Hewlett-Packard driver: r8169 v: kernel port: 3000 bus-ID: 04:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: virbr0 state: down mac: <filter>
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
    driver: btusb v: 0.8 bus-ID: 1-14:10 chip-ID: 8087:0aaa class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Local Storage: total: 709.84 GiB used: 120.53 GiB (17.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: SSD 970 EVO Plus 250GB size: 232.89 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 2B2QEXM7 temp: 44.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 850 PRO 256GB
    size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 4B6Q scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 type: USB vendor: JMicron Tech model: N/A
    size: 238.47 GiB block-size: physical: 4096 B logical: 512 B type: N/A
    serial: <filter> rev: 0504 scheme: MBR
  ID-1: / raw-size: 232.59 GiB size: 227.88 GiB (97.98%)
    used: 120.53 GiB (52.9%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 292 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  Alert: No swap data was found.
  System Temperatures: cpu: 57.0 C pch: 55.0 C mobo: 27.8 C gpu: nvidia
    temp: 49 C
  Fan Speeds (RPM): N/A
  Processes: 310 Uptime: 6m wakeups: 1 Memory: 15.52 GiB
  used: 3.49 GiB (22.5%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.1.0 clang: 13.0.0 Packages: 1554 pacman: 1521 lib: 424 flatpak: 23
  snap: 10 Shell: Zsh v: 5.8 default: Bash v: 5.1.16 running-in: yakuake
  inxi: 3.3.12

At least according to the optional dependency … FF uses networkmanager to determine location by the network. So, assuming you have networkmanager, then I might look at your network settings, such as the router itself.

It usually knows your location by your IP. I agree with cscs, check router. Try connecting directly to modem to rule out router config. Do you have some extension in both browsers that is causing this? Try without extensions.

Does this site detect:

Just in case:

In FF:about:preferences#privacy or settings-Privacy & Security-Permissions-Location- Settings Radio Button on Bottom, make sure you are not blocking. In Chromium, similar: chrome://settings/content

Disabled all extensions on each browser, and reset the router, and still no dice. Used whatismyip, and while it did detect my IPv4, it did not detect my IPv6, so that could have something to do with Hulu not detecting my location, but can’t be totally sure.

In fact, when I disconnect from Wi-Fi it forgets all my network’s security settings, including my password. When I check it in the “Connections” setting, it gives a notification saying “Failed to get secrets for (my network). No agents were available for this request.”, and setting my password manually here doesn’t save either. I’m pretty sure this has something to do with the issue as well, but I’m not sure exactly what’s causing it.

Update: I have been able to save my Wi-Fi settings again and get whatismyip to determine my IPv6 by deleting the existing Wi-Fi/Ethernet connections in the settings, however Hulu still can’t determine my location on either browsers with or without extensions. So it seems this issue goes even deeper than that.

Another Update: Flatpaks and Snaps save the day!.. you would think. I went and downloaded the Flatpak and Snap packages of Chromium, and they both actually booted into Hulu. While this may seem like a win, there are severe issues. While at first, shows and movies seem to play fine, once an ad break comes on, the video crashes. The Flatpak crashes after the ad ends, while the Snap crashes once the ad is supposed to begin, and both cannot play the video past that point. Live TV mode is also completely borked in both packages, the Flatpak saying “Error playing video”, and the Snap saying “We’re having trouble playing this”.

Another thing: I tried some “What is my location?” websites on the official repos and Flatpaks of Firefox and Chromium. Both Flatpaks got my location… not precisely correct, but fairly close around my general area, while the official repos failed to grab it, despite me giving the site location services. This is interesting, since was able to grab my general location from my IP. So it seems the official repos cannot detect my location independent of IP. I originally thought it could have been firewalld interfering, but even after uninstalling, no dice. I don’t see any options in the settings where I can control what applications can see location services (I’m on KDE Plasma btw), and I’m a bit of a noob at the terminal. Does anyone else have any possible way of solving this?

And one more note: Hulu has worked on the official Firefox repo in the past, Live TV and all, so I know it’s not just an issue with the web browser or that it can’t run under Linux at all. It just that one day, it suddenly bricked on me and I’m not sure exactly why, and that’s why I’m asking here how to restore/reverse it.

FINAL UPDATE: Hulu now works on the Firefox official repo… without me doing much of anything. I believe it may have been from a system or application update, or something of the sort that fixed it. So yeah, issue over.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.