Https:// broken in Firefox

Hey all !

What’s up with the Manjaro webpage?
It has been broken for a long time now for me in Firefox, it just appears like a white broken webpage, without CSS.

Basically the webpage is utterless broken in Firefox and unable to navigate.
However, the webpage is running fine on Brave, but isn’t my preferred browser.

And, is running fine in Firefox.

I’ve tried to include a link with a screenshot for you here, but yeah, that wasn’t allowed…

I have also tried to:

  • disable all the extensions in Firefox
  • enable “popup” windows
  • and enabled “standard protection” in the security-tab:
    “Balanced for protection and performance. Pages are normally charged.”

Also, it might been a year or two since I’ve logged on.
Thought it was worth a second go with Manjaro, which brings me to another question - what happened to my old account? old account “Dexter” was gone, and password recovery not working.

this approach is a bit more aggressive:

close firefox
mv ~/.mozilla ~/.mozilla-backup
open it again
you’ll have created a fresh profile that way, but can revert to the old or use it to import some or all of your previous settings

1 Like

It must have been much longer than two years then since your last logon to the forum.

About four years ago, the Manjaro forum suffered a serious data corruption and had to be reinstalled from scratch. Everyone therefore had to register an account all over again. But no accounts have been deleted or anonymized since then without that the member requested us to do so. :man_shrugging:

On account of your firefox problem, follow @Nachlese’s advice, because it does sound like your browser configuration has become corrupted somehow. The site is perfectly visible to me, and I too am using firefox.


Could you have made some changes in about:config?

I was having problems with some things recently and eventually I worked out that I’d made a change I thought would be useful which broke what I actually needed to do.

This type of response usually annoys me, however...

…me too!


To be fair, that kind of response does help to confirm that the problem is probably on OP’s system rather than being due to a problem on the site.


Save your bookmarks, delete firefox and all its configs, start a virgin instance. If it still doesn`t work, you have a serious problem with your system.
Have you changed DNS service to i.e. cloudflare or similar?

1 Like

It’s a vague indicator, at best. To be more certain of a ‘me too’ actually contributiong anything useful, something to the extent of:

‘Me too, and this is why…’

… is preferable; but it’s rare to see that in any constructive fashion.

So, I MOVED .mozilla to .backup and started a new fresh instance.

I always do some tinkering in about:config so I had some suspicions about that being the problem.

about:config and edit:
network.http.sendRefererHeader = 0

That obviously was the source of breaking, or more like death :laughing:
Although, all webpages I use was working fine.

About the deleted account, yeah, I guess that it sounds reasonable that it was a handful of years ago, mystery solved :slight_smile:

Another question though, why is it so important for with RefererHeader that the webpage becomes useless without it?

EDIT: spelling correction

It may be just the wording - but this does not make sense to me.

If you copy, you end up with both the original and the copy.

Starting a fresh instance will then just use the still existing profile in ~/.mozilla (the original)
and literally nothing will have changed …

… you just have a copy of the profile now …

In order to start with a fresh profile
~/.mozilla has to go away first

It will be re-created with default values when the browser is started again.

the value (which I did not change) is “2” in my profile
(just a datapoint)

I’m sorry, it was just a spelling error…
yes ofcourse I meant to say that I moved .mozilla to .backup

and then started a fresh instance
and as yourself confirmed: network.http.sendRefererHeader is initially = 2

try to change it to 0 (like I always do) and then quit Firefox and start it up again, and you’ll see a completely broken webpage

ok - thank you for the clarification :+1:

… why would I even want to try to do that?
I do not know enough about all the flags and options and why they are what they are and what they do and how they affect the browsers behavior.

Nor do I know enough about how the http protocol works … and what could break and why, if something like this is changed
(to achieve what effect or goal?)

To me, this looks like your multilayered assumption (based upon what?)

If you want to increase your browsing security when it comes to sending page referral headers, then you might want to take a look at this page: Security/Referrer - MozillaWiki

Instead of completely disabling the sending of the referring page, there are other options available such as trimming the referral header to just the domain name etc.

Difficult to say - my guess is that manjaro is using the referer internally to create some private metrics of pages viewed, clicked - and in which order.

If you skim the page source you find a private instance of

1 Like

If using the old .mozilla config and changing that value back to 2 fixes it, I’d say that is the solution.