Https Error when trying to run ASP.NET Core WebAPI Projects on Manjaro with Rider

I’m currently trying to develope on a ASP.NET Core WebAPI on my Manjaro System, wich I created with Rider. The Creation just worked fine and it runs with VisualStudio in Windows 10 but I’m getting this (Unhandled exception. System.InvalidOperationException: Unable to configure HTTPS - error from when running in Manjaro. Tried to execute these commands in dotnet but they weren’t aviable. Also tried to disable https for developement but it didn’t work.

I do the same - every day - using Rider - although not the API part but a Blazor WASM api client.

This is a one-time command (no sudo :slight_smile: )

dotnet dev-certs https

I recommend maintaining your LTS dotnet using the custom AUR build script

@linux-aarhus Thanks for your fast answer, I tried to do that several times but it didnt succeed. I installed dotnet and dotnet commands do work in general but the specific dev-certs command does only return this: Usage: dotnet [options]Usage: dotnet [path-to-application]Options: -h|- -
I tried to uninstall dotnet in general and do it the custom LTS way but it seems to behave strange generally because pacman doesn’t find the dotnet package right now.

I have no idea then - I use the PKGBUILD myself - in my usecase - this was the only viable method to get it working.

You have to remove all repo packages you have installed for dotnet.

Do not use pamac to build the package - it will fail.

Use the method describe - it works - do not use pamac - use makepkg

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.