Htop mouse scroll up stopped working after upgrade


Recently I did an big upgrade which ended up breaking my htop mouse wheel scrolling for some reason.

Currently when I run htop I can use my mouse wheel to scroll down the process list, but the scroll up does not scroll up, though it does repaint/refresh it (maintaining the cursor position).
Also, both scrolls work as intended in “sub-menus” like the Setup and/or Enviroment Vars.
Tried it in two different shells: zsh and sh, and other terminals, but to no avail.

So far htop is the only program I’m having this problem with.
Is anyone also having this problem? Or know why this might be happening?
Thanks in advance.

Yes, I can confirm the phenomenon here at my end. You can however scroll back to the top with Ctrl + Home.

The shell doesn’t have anything to do with that. htop is an ncurses-based application ─ ncurses is a framework for writing character-mode user interfaces ─ so I’m guessing it’s probably a bug in ncurses. :thinking:

Yeah, I often use the keyboard to control it most of the time, but this phenomenon is quite annoying when the mouse is the clearly better option.

Also, that key combination (Ctrl + Home) doesn’t work in my case. Just as Home does though.

Oh I see, will be checking their repo for recent changes that might be the cause.

Welp… looks like I didn’t search far enough.
Looking at the htop Github repo I found a few Issues and the fix for this problem :upside_down_face:

This is now fixed in version 3.1.1 of htop.

Manjaro’s mirrors weren’t up to date for this so ended up using Arch’s

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.