HPLIP install laserjet 1102p

This printer needs the propriety plugin. However, when HPLIP downloads the plugin, it returns a checksum error, refusing to go on. Reading up on this, it seems that this usually occurs when you have an older version of HPLIP. My version seems to be 3.20.6 here on manjaro, while 3.20.9 is out now. Strange thing is that Arch seems to be on 3.20.9 already, but I just don’t seem to be able to install it here in Manjaro. Re-installing ends up with 3.20.6 again. Downloaded directly from the HP site, it ends up with all kinds of dependency errors, python qt4 being the major one and it refuses to install. Long story short. I can’t seem to use my Laserjet with Manjaro :frowning: Does anybody know how to do this and can the HPLIP version be updated to the newer version please?

1.) Keep 3.20.6 and download the plugin from…
…this one worked for me, but…
…Edit:…works now too.
Don’t forget to install manjaro-printer for a troublefree setup.
2.) Change to testing and be on 3.20.9 (like arch)

Ah forgot, welcome !

Here i posted a solution for not be able to install a hp printer, it may help you too.

If the checksum fails, wich occurs often, it should give you the option to ignore the checksum and continue the install

The separate downloadable run file worked. Thanks!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.