HP Omen 17 fan/thermal problems

I have a problem with the cooling situation with my hp omen 17 laptop. Under heavy load the fan never reaches max speed until the temperature of the CPU (intel i5-8300H)reaches 95 C and more and does not get lower… Here’s my sensors output:

Adapter: Virtual device
temp1:        +67.0°C  

Adapter: Virtual device
temp1:        +49.0°C  

Adapter: PCI adapter
Composite:    +39.9°C  (low  = -273.1°C, high = +84.8°C)
                       (crit = +84.8°C)
Sensor 1:     +39.9°C  (low  = -273.1°C, high = +65261.8°C)
Sensor 2:     +36.9°C  (low  = -273.1°C, high = +65261.8°C)

Adapter: ISA adapter
Package id 0:  +60.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +59.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +60.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +59.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +60.0°C  (high = +100.0°C, crit = +100.0°C)

Adapter: ACPI interface
in0:          14.80 V  
curr1:            N/A  

Adapter: ACPI interface
temp1:        +63.0°C

I am no specialist, but it seems to me this may be a problem of the “high” and “critical” values of the coretemp-isa-0000 sensor: both the “high” and “crit” values are set to 100 C. I don’t know if this is the problem and how to fix it. I suspect this may be the issue, because the fans do change speed but do not seem to respond adequately to high loads.

My fans don’t seem to be pwm-capable, or at least not recognised, if that will help you. pwmconfig output:

# pwmconfig version 3.6.0+git
This program will search your sensors for pulse width modulation (pwm)
controls, and test each one to see if it controls a fan on
your motherboard. Note that many motherboards do not have pwm
circuitry installed, even if your sensor chip supports pwm.

We will attempt to briefly stop each fan using the pwm controls.
The program will attempt to restore each fan to full speed
after testing. However, it is ** very important ** that you
physically verify that the fans have been to full speed
after the program has completed.

/usr/bin/pwmconfig: There are no pwm-capable sensor modules installed

I’d be really happy if I get some help on this issue.

Dont know whether this might help but there is this wiki…
particularly i8kutils where fan speed change points may be shifted in the config file.
Hope this might shed some light on your problem.

Hi, thanks for your reply.
I have read that wiki page a couple of times. I find it kind of confusing.
Particularly the i8kutils are supposed to work on dell laptops as far as i can see. If I install them on my machine i get the sudo modprobe i8k output:

modprobe: ERROR: could not insert 'dell_smm_hwmon': No such device

Unfortunately this doesn’t seem to solve my problem.

Hi Toncho
I just found this on Phoronix

specifically mentions fan monitoring and the adjuncts to it that appear possible with the new additions. You might want to consider which kernel you are running. I am running on an HP Pavilion Gaming and while I use the machine for photo and video editing I have not noticed anything I consider extreme like you talk about on fan response to heavy loads. Since it is a fairly new laptop I also run GKrellm with monitoring of temps so I keep an eye on things at the sacrifice of screen real estate.

Dont know whether this might help or not but this is my first HP laptop and I have taken somewhat of an interest in them. Performance of mine so far has been flawless. Hopefully someone more knowledgeable than I will also comment here as well. Were I you I might try a later kernel…Michael somewhat implies this upgrade for HP’s might be in 5.16. Whether it is in either Manjo or Arch dont know.

Regards and keep us up to date as you work to resolve this. Might help someone else out there.

Hi expat,
I took a break for the holidays haven somewhat given up on the issue. I will look into the information you have provided to me and keep you updated. Although to be honest, I don’t really want to install the experimental kernel just yet. Thanks a lot!

1 Like

I’m using dell-bios-fan-control in addition to disable BIOS fan control.

Must do:

/etc/modprobe.d/i8k.conf ->editor input-> options i8k force=1

In /etc/modules-load.d/i8k.conf ->editor input-> i8k

Then i8kutils fan control service starts at boot.

Would be great if this is done when installing.

Else must do a >>> sudo modprobe i8k force=1 <<< every reboot to work: systemctl status i8kmon