HP OfficeJet Pro7740 wrong scale of pages / thick borders

Hi there,

i have a problem with my HP OfficeJet Pro7740. Printing on A4 scales the document to sth. like 120 % and makes a thick free border around, so that the printed page is shifted to the left bottom of the paper.
As a result the printed document is much too big for the paper, so that you see only a part of what you wanted to print and on top / right side there is a plain border of about 3-4 cm.
Of course I experimented with different configs in the print dialog, like „scale to paper size“, „print 100%“, „scale to printable size“. Paper size was set to A4. All more or less the same result.
I tried to print from Firefox, Okular, document viewer, Libre office, all the same, so I think it’s a driver/back end problem.

I have installed HP Device manager and even deinstalled HP device manager and Manjaro-printer completly and then reinstalled it. No change.

Then I downloaded a new Manjaro image, started from usb stick, installed HP Device manager in this fresh Linux and all was fine.

So there must be a configuration somewhere, which is re-install resistant or I didn’t reinstall the right tools.

I would be glad, if someone could give me some tip which config file I need to change.


1 Like

A4 vs. Letter format perhaps?

No, not such simple I think.

Definitly not the wrong format size. I did chose A4 by hand, the print dialog shows me the right size in mm, the documents I want to print are in A4.

It must be deeper somewhere in any config file.
As mentioned, if i whant to print exact the same file using manjaro USB-Image it works. I do the same steps there, File to print is stored in my Google drive. So it is the same file. “The file” is just an example, I tried 6 different files. If I print out of the USB-Image of manjaro it is ok, dual boot Windows (same PC, same network hardware from PC to printer) is ok, installed Manjaro on hard drive is not ok.

I attached a picture, how the printed image is moved.


Then you may be using the wrong driver.

You can edit settings in the CUPS web interface https://localhost:631

If you have the option use the driverless IPP/IPPS (Internet Printing Protocol).

Please don’t post images - if it is inevitable use the summary function from the gear icon in the topic/comment editor


I did not get an option for changing this on the installed printer, I tried to install a “new” printer. This did’t work either.

But I restarted my computer to the USB-Image and compared the working driver version there with this non-working on my hard drive Manjaro.
It’s exactly the same driver, so i assume, the driver is working in general.

I really cannot tell - I don’t know where to look - the cups printer service provides some command line utilities - which may be of use.


I usually use those when the system control panel is not enough - those are the same commands executed when you use CUPS webadmin interface.

One can list what is available (example)

 $ lpinfo -v
network https
network socket
network ipps
network beh
network lpd
network ipp
file cups-pdf:/
network http
network smb
network dnssd://Brother%20HL-L8260CDW%20series._ipp._tcp.local/?uuid=e3248000-80ce-11db-8000-b42200ae1e04
network lpd://BRW10B1DF4E61AB/BINARY_P1
network ipp://Brother%20HL-L8260CDW%20series._ipp._tcp.local/

This would provide a information on how the system sees the printer - then one can use the information to accomplish other tasks

I did a quick search - the OfficeJet Pro 7740 does not appear to support ipp everywhere

I assume you - when you can print from the ISO - is using the full ISO.

The meta package manjaro-printer which is included with the full ISO does not include hplip.

So I am thinking that adding hplip package is making the difference between live ISO and you running installation.

Sorry for the long time,
meanwhile I have a completly new installed Manjaro with new home-filder, so no old misconfigurations should be there.

HP sais that for my printer HPLIP-Plugin is not required.

HPLIP GUI starts, let’s me find and install the printer and then claims that the printer might be busy or offline.
But I am able to chose the printer out of libre office / Document viewer and print a page.
It’s a mess, the pages are constantly shifted 4 cm to the right an to the bottom.
If I change the printer driver from “auto:pdf” to “Postscript” I might have a chance, that the page is ONLY shifted to the bottom, and the sides are correct.

I tried Ubuntu in the meantime, it’s the same.
Windows prints correctly.
I think it has to do with HPLIP somehow and the implementation HP is doing there.

I even tried to print via Android, there I shall activate Web-Services and send my data from my home-network via HP-Server to my printer in my home network ?!
I am just frustrated that today obviously it gets more and more complicated just to print at home without sending data round the word using the manufacturer.

The reason, why we have this printer is that my wife uses the A3 scan an print functionality a lot.

Try printing a one page PDF file direct from a terminal eg
lp -d <printer-name> -o media=A4 ~/path/to/foo.pdf
or using ‘fit-to-page’ just to check that scaling works as expected
lp -d <printer-name> -o fit-to-page -o media=A4 ~/path/to/foo.pdf
Use the printer name as shown via
lpstat -a
Does that print as expected? If so, it may be that the issue is with the configured locale in Gnome perhaps?

Also, it might be nice to check the pdf page size using pdfinfo (or similar utility)…
pdfinfo foo.pdf


Wow, thanks. Yes, it printed as expected. In both versions, fit-to-page makes no difference.
So now Ihave to find out, where the misconfigured “locale” is placed?!

At least the driver is eliminated as a cause of the issue. What does the following command report?

These may be worth reviewing re paper size:
Changing default paper size is not retained - #4 by Tomek?
How do I change default paper settings from "letter" to "A4"? - #19 by erAck - English - Ask LibreOffice

Let’s see what others can recommend as well.

Here is my output on locale



Also paperconf brings up “a4”.
Even in `/etc/papersize I declared the paper to be a4.

The printer did an Firmwareupdate an hour ago. This did not change anything.

Printing via lp... command works, the “normal” way of printing out of the GUI does not.

I hope there are other ideas, but I am happy to print somehow with your terminal-command.

The ‘lpoptions’ command can be used to check and set preferred printing options as a user or as an administrator

When run by the root user, lpoptions gets and sets default options and instances for all users in the /etc/cups/lpoptions file. Otherwise, the per-user defaults are managed in the ~/.cups/lpoptions file.

Another article describing the use of lpoptions

FWIW, I found one CUPS list thread describing a potential scaling issue that may be relevant to your situation (no promises though)
It suggests setting media=A4, fitplot=true, and fit-to-page=true can be used together if needed.

That could be done as user with

lpoptions -o media=A4 - o fitplot=true -o fit-to-page=true

You can check ~/.cups/lpoptions to see the applied user-level options. Easy enough to remove if a mistake is made or it doesn’t have the desired effect.