Changing default paper size is not retained

I have successfully added a printer (Fuji Xerox DocuPrint C3055 DX). It’s gotten all the toner data and seems to be working fine, but test prints fail because the paper size is wrong.

But when I click “Configure” and change the default paper size, the setting is not retained. If I immediately open the same configuration window again it’s back to US Letter, not A4 like I had set.

Any suggestions? If I open a program and override the system defaults it works (until I restart the application and it reloads the system defaults and goes back to US Letter), so I know the printer will work great once I manage to get it to retain the page size.

I am using the Fuji Xerox CM305 df Foomatic/Postscript driver that ships with Manjaro (and which is the driver recommended for this printer).

I think you have to change it in the system config or directly in cups.

The print menu only changes this per session, I think.

It doesn’t even retain it within the same session… I can have the main printer dialogue window open, hit config, change the paper size, hit apply and OK to close the window, hit configure immediately and it’s back to US Letter.

You should set your preferred paper size in /etc/papersize. You can check current setting via paperconf command and change via paperconfig, for example

sudo paperconfig -p a4
1 Like

For a second I thought you were trolling me those commands were so plain and simple. I’ll mark your post as the Solution. Thankyou!


Isn’t it a bit of a red herring to have a setting in a dialogue for the activity I am doing that doesn’t work? I mean, it’s in the GUI because it worked for someone, some time, right? Your work around is great, but how do I report an element of the settings GUI not working so it gets fixed? Is there a bug tracker for Manjaro somewhere? Or it this the right place to get it sorted? Or do I go to the KDE team? Is this a problem specific to the Manjaro/Arch implementation of KDE?

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.