HP Laserjet 1018 install nightmare

Hi all.

I am new to Manjaro (but have some Linux experience; mostly Mint/Ubuntu).

Since installing Manjaro a few weeks ago, I have had a nightmare trying to get my HP Laserjet 1018 (USB) installed. I’ve tried many things, and have probably broken some things along the way. I could really do with some help fixing my mess.

I’ve tried (unsuccessfully):

  • HP Printer Setup (GUI and command line)
  • CUPS web interface
  • system-config-printer
  • the proprietary HP driver
  • the foo2zjs driver
  • installing and uninstalling various combinations of software and drivers

I have occasionally been able to get something to print, but:

  • I frequently get a popup dialog telling me I need to install a driver (even though that’s literally what I’ve been trying to do for hours).
  • The printer frequently seems to lose its USB connection (and I have to try various things to refresh the connection, and even then I can’t seem to get it to print reliably).
  • I even had a problem the other day where 90GB of free disk space filled up in a matter of hours because CUPS was furiously writing something to one of the logs (access.log, I think). I deleted the log and rebooted, and it seems OK now, but that was certainly interesting.
  • BTW, the same printer worked reliably under Mint/Ubuntu for years.

Can somebody please help me get this set up correctly? I’d really appreciate your help!

(Note: At this point I don’t really know what I have installed correctly, and basically need to start from scratch.)

Thanks,
Greg

I feel your pain, I’m going through this with my HP 1006 every time i install any linux distro. I had quite good success with hp-setup in the past. hp-setup is also available in Manjaro.

https://developers.hp.com/hp-linux-imaging-and-printing/install/manual/hp_setup

good luck.

Thank you @Alchemix. I’ll give that another try.

BTW, I think I’ve finally worked out that the printer itself has gone bad. Couldn’t get it working on either an Ubuntu machine or a Windows machine. Placed an order for something new.

Hi, @gtorrance,
I think the problem could be solved reading the recipe I wrote on this post.
https://forum.manjaro.org/t/basic-linux-compatible-printer/28597/7

Hope it help, regards.