HP Envy x360 - action keys mode is randomly enabled


I own an HP Envy x360 laptop with Ryzen 5 3500U. I’ve already resolved most of the annoying issues I’ve had with it, but there’s this one thing I have no idea how to approach.

When I turn on my computer, the action keys are sometimes enabled by default despite Action Keys Mode being explicitly disabled in the BIOS. I can usually resolve that problem by rebooting, because say 75% of the time the keyboard behaves as expected and the keys function as F1-F12.

I haven’t found anyone describing a similar problem yet, hence my question - what could be the cause of such behavior and what can be done to fix it?

Thank you!

I don’t know what info to provide in this case, but I suppose inxi -Fxxxz is good for start:

  Kernel: 5.8.6-1-MANJARO x86_64 bits: 64 compiler: N/A 
  Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.0 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Convertible System: HP product: HP ENVY x360 Convertible 13-ar0xxx 
  v: N/A serial: <filter> Chassis: type: 31 serial: <filter> 
  Mobo: HP model: 85DE v: 41.36 serial: <filter> UEFI: AMI v: F.19 
  date: 12/26/2019 
  ID-1: BAT0 charge: 39.5 Wh condition: 52.5/52.5 Wh (100%) volts: 15.9/15.4 
  model: 333-2B-49-A KC04053XL type: Li-ion serial: <filter> 
  status: Discharging 
  Device-1: hid-0018:04F3:23AE.0001-battery model: ELAN2514:00 04F3:23AE 
  serial: N/A charge: N/A status: N/A 
  Topology: Quad Core model: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx 
  bits: 64 type: MT MCP arch: Zen+ rev: 1 L2 cache: 2048 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 33551 
  Speed: 1252 MHz min/max: 1400/2100 MHz boost: enabled Core speeds (MHz): 
  1: 1286 2: 1272 3: 1222 4: 1222 5: 1223 6: 1224 7: 1228 8: 1223 
  Device-1: AMD Picasso vendor: Hewlett-Packard driver: amdgpu v: kernel 
  bus ID: 04:00.0 chip ID: 1002:15d8 
  Display: x11 server: X.Org 1.20.8 compositor: kwin_x11 driver: amdgpu 
  FAILED: ati unloaded: modesetting alternate: fbdev,vesa 
  resolution: 1920x1080~60Hz s-dpi: 96 
  OpenGL: renderer: AMD RAVEN (DRM 3.38.0 5.8.6-1-MANJARO LLVM 10.0.1) 
  v: 4.6 Mesa 20.1.7 direct render: Yes 
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus ID: 04:00.1 chip ID: 1002:15de 
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor 
  vendor: Hewlett-Packard driver: snd_rn_pci_acp3x v: kernel bus ID: 04:00.5 
  chip ID: 1022:15e2 
  Device-3: AMD Family 17h HD Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus ID: 04:00.6 chip ID: 1022:15e3 
  Sound Server: ALSA v: k5.8.6-1-MANJARO 
  Device-1: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter 
  vendor: Hewlett-Packard driver: rtw_8822be v: N/A port: f000 
  bus ID: 02:00.0 chip ID: 10ec:b822 
  IF: wlan0 state: up mac: <filter> 
  Local Storage: total: 476.94 GiB used: 110.83 GiB (23.2%) 
  ID-1: /dev/nvme0n1 model: KBG30ZMV512G KIOXIA size: 476.94 GiB 
  speed: 15.8 Gb/s lanes: 2 serial: <filter> rev: ADHA0102 scheme: GPT 
  ID-1: / size: 255.08 GiB used: 110.12 GiB (43.2%) fs: ext4 
  dev: /dev/nvme0n1p5 
  ID-1: swap-1 type: partition size: 16.00 GiB used: 664.5 MiB (4.1%) 
  priority: -2 dev: /dev/nvme0n1p6 
  System Temperatures: cpu: 46.5 C mobo: 40.0 C gpu: amdgpu temp: 46 C 
  Fan Speeds (RPM): N/A 
  Processes: 288 Uptime: 1h 02m Memory: 5.74 GiB used: 4.83 GiB (84.1%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 clang: 10.0.1 Packages: 
  pacman: 1617 Shell: Bash v: 5.0.18 running in: konsole inxi: 3.1.05 


Not sure how relevant, but probably the kernel in use right now is not actually helping, and you should see if any of this discussion shades some ideas:

Hah! I had the same thing a few years ago and found what was causing this:
Back then on an HP, pressing Fn+Esc instead of Ctrl+Esc activated the action keys too and the “random” factor happened to be my fat fingers pressing the wrong key combination…

YMMV, but I’m giving you a high probability you’re having the same error: PEBCAK!

:grin: :wink:

P.S. Yes, I had them deactivated in the BIOS too, but took me a few reboots before finding what the cause was…

Thank you for your replies!

@bogdancovaciu Thank you for the forum link. I can’t really judge how closely the sensors are related to the keyboard in this laptop, but I will try to do some digging. As for kernel versions, I’ve been using 5.7 and 5.8 and the problem occurs on both. I might try out 5.9 to see if it helps.

@Fabby, unfortunately I don’t think that’s the case here :slightly_frowning_face: The action keys are active right from the start, so the only I’m touching before is the power button. I tried all sorts of wild key combinations involving Fn to see if it there’s any that could cause it to become inverted, but with no luck.

Ah, I should add that reloading atkbd kernel module doesn’t change the behavior of the keys either.

1 Like

From the Official HP Documentation:

Press Fn and left shift key at the same time to enable the action keys (function) mode.


I think you are referring to documentation for EliteBook and ProBook. My keyboard looks like this - there’s no fn lock on Shift nor any LED on the Fn key:

I tried that combination once again just to be sure, but sadly it didn’t work

1 Like