HP dc7700p installation problems

Dear fellow users,

a fairly old (manufactured 2007) HP PC was given to me recently, and I intend to use it as my main computer. The output of inxi -Fxz is as follows:

Kernel: 5.4.0-53-generic x86_64 bits: 64 compiler: gcc v: 9.3.0
Desktop: Xfce 4.14.2 Distro: Ubuntu 20.04.1 LTS (Focal Fossa)
Type: Desktop System: Hewlett-Packard
product: HP Compaq dc7700p Convertible Minitower v: N/A serial:
Mobo: Hewlett-Packard model: 0A58h serial: BIOS: Hewlett-Packard
v: 786E1 v02.10 date: 04/13/2007
Topology: Dual Core model: Intel Core2 6400 bits: 64 type: MCP
arch: Core Merom rev: 2 L2 cache: 2048 KiB
flags: lm nx pae sse sse2 sse3 ssse3 vmx bogomips: 8505
Speed: 1595 MHz min/max: 1596/2133 MHz Core speeds (MHz): 1: 1595 2: 1595
Device-1: NVIDIA GK208B [GeForce GT 710] vendor: Micro-Star MSI
driver: nouveau v: kernel bus ID: 01:00.0
Display: x11 server: X .Org 1.20.8 driver: nouveau
unloaded: fbdev,modesetting,vesa resolution: 1280x1024~60Hz
OpenGL: renderer: NV106 v: 4.3 Mesa 20.0.8 direct render: Yes
Device-1: NVIDIA GK208 HDMI/DP Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel bus ID: 01:00.1
Sound Server: ALSA v: k5.4.0-53-generic
Device-1: Intel 82566DM Gigabit Network vendor: Hewlett-Packard
driver: e1000e v: 3.2.6-k port: 2100 bus ID: 00:19.0
IF: enp0s25 state: up speed: 1000 Mbps duplex: full mac:
Local Storage: total: 223.57 GiB used: 6.55 GiB (2.9%)
ID-1: /dev/sda vendor: Crucial model: CT240BX500SSD1 size: 223.57 GiB
ID-1: / size: 218.12 GiB used: 6.55 GiB (3.0%) fs: ext4 dev: /dev/dm-0
ID-2: swap-1 size: 980.0 MiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-1
System Temperatures: cpu: 42.0 C mobo: N/A gpu: nouveau temp: 42 C
Fan Speeds (RPM): N/A
Processes: 170 Uptime: 4m Memory: 7.65 GiB used: 497.7 MiB (6.4%)
Init: systemd runlevel: 5 Compilers: gcc: N/A Shell: bash v: 5.0.17
inxi: 3.0.38

As you can see, Ubuntu 20.04.1 LTS is currently installed on the device. Originally someone installed Ubuntu 18.04 for me and I upgraded to 20.04.1.

The reason I’m writing this post is that I need help with the installation of Manjaro on the aforementioned computer.
In accordance with the Manjaro User Guide I downloaded the latest version of Manjaro KDE edition (filename: manjaro-kde-20.1.2-201019-linux58.iso) and “burned” it to a USB flash drive using dd. After that I verified that the iso was not corrupted (using the SHA1 checksum).

Then, of course, I tried to install Manjaro, but the computer didn’t boot from the USB drive. I changed several options in the BIOS and tried again, but to no avail. Depending on which options I set, the computer either booted from the internal harddrive or didn’t boot at all. I don’t know if the bios even detected the USB pen drive.

To make shure that there was nothing wrong with the USB drive, I tried to boot from it on a (much newer) laptop, and, shure enough, it booted without any major problems.

My question to you is: How can I get that Manjaro USB drive to boot on my HP dc7700p computer? Are there any specific settings I have to set on that particular computer (The BIOS seems to be much more complex than the one on my laptop)?

Thanks for any help!

All the best, Vivian

If you boot to your existing install, then plug in the USB drive, does it get detected?

@merlock Thanks for answering! Yes, it gets detected.


I’m not very knowledgeable in Manjaro, but my recent experience shows that UEFI is needed and I wonder if that system of 2007 has that capability. And indeed Ubuntu can boot in legacy mode but the latest Manjaro not.

Plenty of information about your relic computer here.

In particular:

Computer Setup (F10) Utility Guide

Look at table 3 (Computer Setup / Storage / Storage Options)

Then look around your BIOS for an option that might say something like:

Removable Media Boot

UEFI is certainly not a prerequisite. It could perfectly works on BIOS systems as mine.

On my Dell 6430 the install only worked in UEFI mode where Ubuntu had no problems with the legacy setup. YMMV every system is different.

Exactly. I’ve changed from MBR to GPT on my legacy Dell 6520.

Thanks for all the answers!

@merlock Yes, this computer is a relic, unfortunately. :sleepy: I have read through the manual you kindly posted here. As it turned out, the option “Removable Media Boot” is already set to “enable” by default. I reset the BIOS to the default settings, and the computer booted, but it completely ignored that I chose to boot from my USB pendrive in the boot menu - it booted from the harddrive anyway.

I tried a few other options from the manual, but changing them resulted in the computer hanging with a blinking cursor in the top left corner of the screen. :frowning:

@jdeca57 @Falav I highly doubt that this 2007 machine has any UEFI capability. UEFI was quite a new and relatively uncommon thing in 2007, as I’ve read on the UEFI wikipedia page.

Does the machine have an optical drive? If so, you can try burning a disk, and attempt to boot that.

1 Like

Which program did you use to flash Manjaro on an USB key? Try maybe another program such as Ventoy, Etcher, OpenSuseWriter…
If still not working, if you have one, try also with a second USB key, different than the one you used initially.

And you have also the possibility to mount an iso from grub following @Chrysostomus tutorial [HowTo] Booting manjaro iso directly with grub

It can make your system boot from an iso directly on your hard drive. I successfully tested it from my Manjaro system, I guess it should work also from Ubuntu.

Ubuntu has slightly different boot entry, but the same approach works.

Edit: If you are trying to install manjaro, the boot entry is exactly the same. Remember the set copytoram parameter, otherwise you can’t partition the disk where the iso is located.

Finally I can tell you that I’ve had some success!
@Falav @Chrysostomus @merlock I’m so thankful that you all posted on my topic! Without that encouragement I’d have given up before long.

@merlock I want to thank you in particular for looking up all the HP manuals and for your last hint concerning booting from DVD. I’ve read through the manuals, and in one of them I discovered (if I understood that correctly) that my HP PC cannot boot directly from USB. Booting from USB would only work if I first booted from floppy disc (!) and even then I don’t know if it would have worked.
So I bought some DVDs, burned the iso to one of them, and - it booted at first try! The installation seems to have been successful. :slightly_smiling_face:

However, I might have done something wrong : After the installation had finished, I expected some kind of prompt that I could now remove the installation medium, but it just rebooted without any prompt, and, since the DVD was still in the drive, it booted once again into the live DVD. I removed the DVD and tried to reboot, but it didn’t work, so I had to press and hold the power button until the PC turned off. Ever since, the PC boots into Manjaro, BUT it needs a lot more time than I think it should, and I get the following error message on every bootup: [failed] failed to start LVM2 PV scan on device 8:1.

Does anyboody know what that means and what I could do to solve the problem? Maybe it is related to the DVD-Rom-Drive? pvdisplay gives the following output:

Glad to hear that you’ve got it booting and installed.

I have no experience with LVM…

ETA: You should open a new thread for your LVM issues…

Ah, thanks, I was wondering if I should start a new thread about the LVM2 error messages. Fortunately, I was able to solve the problem by myself. Apparently, there was still a “ghost partition” left which originated from the former Xubuntu install that was somehow interfering with Manjaro. After deleting this partition and powercycling the computer, the error messages disappeared. The boot time still seams rather long to me, but maybe that’s normal, and it is a minor inconvenience anyway.
So, I declare this glorious thread closed. Thanks again for your help and patience!


Glad to see that you’ve worked it out. You can start a new thread about optimization of your boot time if you want, or first check the forum. There are some related threads that could give you some advice.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.