HP 290 G4 Microtower PC and Manjaro Xfce...lots of problems

Hi, I bouth a new pc, an HP 290 G4 Microtower PC Intel i3-10100 (8) @ 4.300GHz Intel CometLake-S GT2 [UHD Graphics 630] Ram 7776 MiB freedos.
I installed manjaro xfce but since then I had a lot of problems:

  1. Ther’s a tic-tic that comes from the speaker.

They told me to put in the terminal

sudo su
echo 0 > /sys/module/snd_hda_intel/parameters/power_save

But every time I open the pc it returns, then they suggested me to do:

sudo touch /usr/local/set-audio-workaroud.sh
sudo chmod +x /usr/local/set-audio-workaround.sh
sudo nano /usr/local/set-audio-workaround.sh

Modify the file like this:

#!/usr/bin/env bash
echo 0 > /sys/module/snd_hda_intel/parameters/power_save


nano /etc/systemd/system/set-audio-workaround.service

Modify like this

Description=Audio workaround




sudo systemctl enable --now set-audio-workaround.service

But it doesn’t work and the tic tic remains and the parameter returns to 1 every time I open the pc.

  1. I use toolbox for cleaning and the rest end and it reported me this:
 checking systemctl ...
  The following systemd service(s) have failed. Please fix them manually. 
  Display detailed information about a systemd service with: systemctl status <SYSTEMD SERVICE NAME> 

  UNIT                   		    LOAD	ACTIVE	SUB 	DESCRIPTION            
● pkgfile-update.service     		loaded	failed	failed	pkgfile database update
● set-audio-workaround.service 		loaded	failed	failed	Audio workaround

LOAD   = Reflects whether the unit definition was properly loaded.
ACTIVE = The high-level unit activation state, i.e. generalization of SUB.
SUB    = The low-level unit activation state, values depend on unit type.
2 loaded units listed.

I don’t know how to fix them and I think the problem it’s related to the one above.

  1. Toolbox also reported me a problem whit chromium.
checking symlinks ...
  The following symbolic links are broken, please fix them manually:

In the old pc it was a problem that I fixed removing gnome-keyring but now it doesn’t work.
I tried to fix using this guide but nothing and the files returns every time I open the pc.

Lilke you see I have a lot of problems…sorry if I put all in one topic but if the problems are related I prefere to concentrate the efforts.
Every ne that has an idea I’d like to hear it.
Thank to everyone.

Well it is module…

modinfo snd_hda_intel
sudo modprobe -vr snd_hda_intel
sudo modprobe -v snd_hda_intel power_save=0

Kernel module - ArchWiki

Sorry I posted before finish to write for error…I edited now the firs post.

So what error? What relationship has chromium with the sound module? Sorry…

However the approach to use a service is wrong when you need to set parameters for a module. There system services which does it for you. Just set a configuration file as described in the wiki I linked.

By the way: What are you calling a “Toolbox” ? No idea what you mean by that.

I don’t know, I just believed they could be connected in some way…

These are the results:

[iwakura@iwakura-hp290g4microtowerpc ~]$ modinfo snd_hda_intel
filename:       /lib/modules/5.15.76-1-MANJARO/kernel/sound/pci/hda/snd-hda-intel.ko.xz
description:    Intel HDA driver
license:        GPL
srcversion:     5E390614244958F5C550A67
alias:          pci:v00001D17d00003288sv*sd*bc*sc*i*
alias:          pci:v00001022d*sv*sd*bc04sc03i00*
alias:          pci:v00001002d*sv*sd*bc04sc03i00*
alias:          pci:v000015ADd00001977sv*sd*bc*sc*i*
alias:          pci:v000017F3d00003010sv*sd*bc*sc*i*
alias:          pci:v000013F6d00005011sv*sd*bc*sc*i*
alias:          pci:v00001102d00000009sv*sd*bc*sc*i*
alias:          pci:v00001102d00000012sv*sd*bc*sc*i*
alias:          pci:v00001102d00000010sv*sd*bc*sc*i*
alias:          pci:v00006549d00002200sv*sd*bc*sc*i*
alias:          pci:v00006549d00001200sv*sd*bc*sc*i*
alias:          pci:v000010DEd*sv*sd*bc04sc03i00*
alias:          pci:v000010B9d00005461sv*sd*bc*sc*i*
alias:          pci:v00001039d00007502sv*sd*bc*sc*i*
alias:          pci:v00001106d00009140sv*sd*bc*sc*i*
alias:          pci:v00001106d00009170sv*sd*bc*sc*i*
alias:          pci:v00001106d00003288sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AB38sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AB28sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AB20sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AB18sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AB10sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AB08sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AB00sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AAF8sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AAF0sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AAE8sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AAE0sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AAD8sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AAC8sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AAC0sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AAB0sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AAA8sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AAA0sv*sd*bc*sc*i*
alias:          pci:v00001002d00009902sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AA98sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AA90sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AA88sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AA80sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AA68sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AA60sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AA58sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AA50sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AA48sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AA40sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AA38sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AA30sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AA28sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AA20sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AA18sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AA10sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AA08sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AA00sv*sd*bc*sc*i*
alias:          pci:v00001002d00009840sv*sd*bc*sc*i*
alias:          pci:v00001002d0000970Fsv*sd*bc*sc*i*
alias:          pci:v00001002d0000960Fsv*sd*bc*sc*i*
alias:          pci:v00001002d00007919sv*sd*bc*sc*i*
alias:          pci:v00001002d0000793Bsv*sd*bc*sc*i*
alias:          pci:v00001002d000015B3sv*sd*bc*sc*i*
alias:          pci:v00001002d0000157Asv*sd*bc*sc*i*
alias:          pci:v00001002d00001308sv*sd*bc*sc*i*
alias:          pci:v00001002d00000002sv*sd*bc*sc*i*
alias:          pci:v00001022d000015E3sv*sd*bc*sc*i*
alias:          pci:v00001022d0000157Asv*sd*bc*sc*i*
alias:          pci:v00001022d00001487sv*sd*bc*sc*i*
alias:          pci:v00001022d00001457sv*sd*bc*sc*i*
alias:          pci:v00001022d0000780Dsv*sd*bc*sc*i*
alias:          pci:v00001002d00004383sv*sd*bc*sc*i*
alias:          pci:v00001002d0000437Bsv*sd*bc*sc*i*
alias:          pci:v00008086d*sv*sd*bc04sc03i00*
alias:          pci:v00008086d00003A6Esv*sd*bc*sc*i*
alias:          pci:v00008086d00003A3Esv*sd*bc*sc*i*
alias:          pci:v00008086d0000293Fsv*sd*bc*sc*i*
alias:          pci:v00008086d0000293Esv*sd*bc*sc*i*
alias:          pci:v00008086d0000284Bsv*sd*bc*sc*i*
alias:          pci:v00008086d0000269Asv*sd*bc*sc*i*
alias:          pci:v00008086d000027D8sv*sd*bc*sc*i*
alias:          pci:v00008086d00002668sv*sd*bc*sc*i*
alias:          pci:v00008086d00002284sv*sd*bc*sc*i*
alias:          pci:v00008086d00000F04sv*sd*bc*sc*i*
alias:          pci:v00008086d0000080Asv*sd*bc*sc*i*
alias:          pci:v00008086d0000811Bsv*sd*bc*sc*i*
alias:          pci:v00008086d00003B57sv*sd*bc*sc*i*
alias:          pci:v00008086d00003B56sv*sd*bc*sc*i*
alias:          pci:v00008086d0000160Csv*sd*bc*sc*i*
alias:          pci:v00008086d00000D0Csv*sd*bc*sc*i*
alias:          pci:v00008086d00000C0Csv*sd*bc*sc*i*
alias:          pci:v00008086d00000A0Csv*sd*bc*sc*i*
alias:          pci:v00008086d00003198sv*sd*bc*sc*i*
alias:          pci:v00008086d00001A98sv*sd*bc*sc*i*
alias:          pci:v00008086d00005A98sv*sd*bc*sc*i*
alias:          pci:v00008086d00004B58sv*sd*bc*sc*i*
alias:          pci:v00008086d00004B55sv*sd*bc*sc*i*
alias:          pci:v00008086d000051CCsv*sd*bc*sc*i*
alias:          pci:v00008086d000051C8sv*sd*bc*sc*i*
alias:          pci:v00008086d00007AD0sv*sd*bc*sc*i*
alias:          pci:v00008086d00004F92sv*sd*bc*sc*i*
alias:          pci:v00008086d00004F91sv*sd*bc*sc*i*
alias:          pci:v00008086d00004F90sv*sd*bc*sc*i*
alias:          pci:v00008086d0000490Dsv*sd*bc*sc*i*
alias:          pci:v00008086d000043C8sv*sd*bc*sc*i*
alias:          pci:v00008086d0000A0C8sv*sd*bc*sc*i*
alias:          pci:v00008086d00004DC8sv*sd*bc*sc*i*
alias:          pci:v00008086d000038C8sv*sd*bc*sc*i*
alias:          pci:v00008086d00003DC8sv*sd*bc*sc*i*
alias:          pci:v00008086d000034C8sv*sd*bc*sc*i*
alias:          pci:v00008086d0000F0C8sv*sd*bc*sc*i*
alias:          pci:v00008086d0000A3F0sv*sd*bc*sc*i*
alias:          pci:v00008086d0000F1C8sv*sd*bc*sc*i*
alias:          pci:v00008086d000006C8sv*sd*bc*sc*i*
alias:          pci:v00008086d000002C8sv*sd*bc*sc*i*
alias:          pci:v00008086d00009DC8sv*sd*bc*sc*i*
alias:          pci:v00008086d0000A348sv*sd*bc*sc*i*
alias:          pci:v00008086d0000A2F0sv*sd*bc*sc*i*
alias:          pci:v00008086d00009D71sv*sd*bc*sc*i*
alias:          pci:v00008086d0000A171sv*sd*bc*sc*i*
alias:          pci:v00008086d00009D70sv*sd*bc*sc*i*
alias:          pci:v00008086d0000A170sv*sd*bc*sc*i*
alias:          pci:v00008086d00009CA0sv*sd*bc*sc*i*
alias:          pci:v00008086d00009C21sv*sd*bc*sc*i*
alias:          pci:v00008086d00009C20sv*sd*bc*sc*i*
alias:          pci:v00008086d0000A270sv*sd*bc*sc*i*
alias:          pci:v00008086d0000A1F0sv*sd*bc*sc*i*
alias:          pci:v00008086d00008D21sv*sd*bc*sc*i*
alias:          pci:v00008086d00008D20sv*sd*bc*sc*i*
alias:          pci:v00008086d00008CA0sv*sd*bc*sc*i*
alias:          pci:v00008086d00008C20sv*sd*bc*sc*i*
alias:          pci:v00008086d00001E20sv*sd*bc*sc*i*
alias:          pci:v00008086d00001D20sv*sd*bc*sc*i*
alias:          pci:v00008086d00001C20sv*sd*bc*sc*i*
depends:        snd-hda-core,snd-hda-codec,snd-pcm,snd,snd-intel-dspcfg
retpoline:      Y
intree:         Y
name:           snd_hda_intel
vermagic:       5.15.76-1-MANJARO SMP preempt mod_unload 
sig_id:         PKCS#7
signer:         Build time autogenerated kernel key
sig_key:        3F:04:31:F1:D2:19:B7:1A:3A:45:CB:A2:0B:A9:B7:FD:95:C9:3A:B9
sig_hashalgo:   sha512
signature:      30:65:02:31:00:DD:C1:20:32:31:68:46:4C:17:B5:81:A9:77:E7:BF:
parm:           index:Index value for Intel HD audio interface. (array of int)
parm:           id:ID string for Intel HD audio interface. (array of charp)
parm:           enable:Enable Intel HD audio interface. (array of bool)
parm:           model:Use the given board model. (array of charp)
parm:           position_fix:DMA pointer read method.(-1 = system default, 0 = auto, 1 = LPIB, 2 = POSBUF, 3 = VIACOMBO, 4 = COMBO, 5 = SKL+, 6 = FIFO). (array of int)
parm:           bdl_pos_adj:BDL position adjustment offset. (array of int)
parm:           probe_mask:Bitmask to probe codecs (default = -1). (array of int)
parm:           probe_only:Only probing and no codec initialization. (array of int)
parm:           jackpoll_ms:Ms between polling for jack events (default = 0, using unsol events only) (array of int)
parm:           single_cmd:Use single command to communicate with codecs (for debugging only). (bint)
parm:           enable_msi:Enable Message Signaled Interrupt (MSI) (bint)
parm:           patch:Patch file for Intel HD audio interface. (array of charp)
parm:           beep_mode:Select HDA Beep registration mode (0=off, 1=on) (default=1). (array of bool)
parm:           dmic_detect:Allow DSP driver selection (bypass this driver) (0=off, 1=on) (default=1); deprecated, use snd-intel-dspcfg.dsp_driver option instead (bool)
parm:           power_save:Automatic power-saving timeout (in second, 0 = disable). (xint)
parm:           pm_blacklist:Enable power-management denylist (bool)
parm:           power_save_controller:Reset controller in power save mode. (bool)
parm:           align_buffer_size:Force buffer and period sizes to be multiple of 128 bytes. (bint)
parm:           snoop:Enable/disable snooping (bint)
[iwakura@iwakura-hp290g4microtowerpc ~]$ sudo modprobe -vr snd_hda_intel
[sudo] password di iwakura: 
modprobe: FATAL: Module snd_hda_intel is in use.
[iwakura@iwakura-hp290g4microtowerpc ~]$ sudo modprobe -v snd_hda_intel power_save=0

And it does not work…or did I do something wrong?

You can find under the name bmenu in pamac.

Can be a bios problem? Maybe that it need an update?

systemctl command does not need sudo. Password will be requested if root privileges are needed
(1st point of potential failure)

I have never seen a systemd service used in this way before. I suspect 2nd potential failure due to After=sound.target I don’t think this is the right condition to use for this unit, but not sure what it could be replaced with

BASH script /usr/local/set-audio-workaround.sh might be 3rd potential failure, but script contents are unknown

Simplest way I know of to use both modprobe options to disable power saving does not need a systemd service or script:

sudo tee /etc/modprobe.d/ <<< 'options snd_hda_intel power_save=0 power_save_controller=N'

Pops when starting and stopping playback - Advanced Linux Sound Architecture/Troubleshooting - ArchWiki

Power management changes might also be overruled by tlp.service

I suggest check tlp configuration

sudo tlp-stat | grep -E 'SOUND|snd'

For a desktop system it might be preferable to disable tlp rather than reconfiguring it

systemctl mask tlp.service

Are you taking about this command?

sudo systemctl enable --now set-audio-workaround.service

I put the command in the terminal without sudo and will see next time I open the pc.

Boh…the file was created for solve the problem and originally it was like this:

Description=Audio workaround



And because it didn’t work it was modified as shown in the first post.

What do you mean that the script contents are unknown?
I can read the script and it’s this:

I created it like I said i the first post…

This is the result, next time I open the pc I will see if it works.

[iwakura@iwakura-hp290g4microtowerpc ~]$ sudo tee /etc/modprobe.d/ <<< 'options snd_hda_intel power_save=0 power_save_controller=N'
[sudo] password di iwakura: 
tee: /etc/modprobe.d/: È una directory
options snd_hda_intel power_save=0 power_save_controller=N

È una directory means It is a directory…The system is in italian language.

I will try this if the other solutions don’t work.


If set-audio-workaround.service is not working I suggest you check for error messages that may explain why it is not working

systemctl -l --no-pager status set-audio-workaround.service sound.target

What do you mean that the script contents are unknown?

script was not included in post#1
The script can be ruled out as a potential point of failure if it works when run from terminal

È una directory

Apologies. My error for omitting a filename

sudo tee /etc/modprobe.d/snd-hda-intel-power.conf <<< 'options snd_hda_intel power_save=0 power_save_controller=N'

buona fortuna


[iwakura@iwakura-hp290g4microtowerpc ~]$ systemctl -l --no-pager status set-audio-workaround.service sound.target
× set-audio-workaround.service - Audio workaround
Loaded: loaded (/etc/systemd/system/set-audio-workaround.service; enabled; preset: disabled)
Active: failed (Result: exit-code) since Fri 2022-11-11 11:19:49 CET; 1h 3min ago
Process: 402 ExecStart=/usr/local/set-audio-workaround.sh (code=exited, status=1/FAILURE)
Main PID: 402 (code=exited, status=1/FAILURE)
CPU: 4ms

nov 11 11:19:49 iwakura-hp290g4microtowerpc systemd[1]: Starting Audio workaround…
nov 11 11:19:49 iwakura-hp290g4microtowerpc set-audio-workaround.sh[402]: /usr/local/set-audio-workaround.sh: riga 2: /sys/module/snd_hda_intel/parameters/power_save: File o directory non esistente
nov 11 11:19:49 iwakura-hp290g4microtowerpc systemd[1]: set-audio-workaround.service: Main process exited, code=exited, status=1/FAILURE
nov 11 11:19:49 iwakura-hp290g4microtowerpc systemd[1]: set-audio-workaround.service: Failed with result ‘exit-code’.
nov 11 11:19:49 iwakura-hp290g4microtowerpc systemd[1]: Failed to start Audio workaround.

● sound.target - Sound Card
Loaded: loaded (/usr/lib/systemd/system/sound.target; static)
Active: active since Fri 2022-11-11 11:19:50 CET; 1h 3min ago
Until: Fri 2022-11-11 11:19:50 CET; 1h 3min ago
Docs: man:systemd.special(7)

nov 11 11:19:50 iwakura-hp290g4microtowerpc systemd[1]: Reached target Sound Card.

And this…

[iwakura@iwakura-hp290g4microtowerpc ~]$ sudo tee /etc/modprobe.d/snd-hda-intel-power.conf <<< ‘options snd_hda_intel power_save=0 power_save_controller=N’
[sudo] password di iwakura:
options snd_hda_intel power_save=0 power_save_controller=N

…didn’t worked…

For this:

sudo tlp-stat | grep -E 'SOUND|snd'

and this:

systemctl mask tlp.service

There results are:

[iwakura@iwakura-hp290g4microtowerpc ~]$ sudo tlp-stat | grep -E ‘SOUND|snd’
[sudo] password di iwakura:
defaults.conf L0035: SOUND_POWER_SAVE_ON_AC=“1”
defaults.conf L0036: SOUND_POWER_SAVE_ON_BAT=“1”
defaults.conf L0037: SOUND_POWER_SAVE_CONTROLLER=“Y”
/sys/module/snd_hda_intel/parameters/power_save = 1
/sys/module/snd_hda_intel/parameters/power_save_controller = Y
/sys/bus/pci/devices/0000:00:1f.3/power/control = auto (0x040300, Audio device, snd_hda_intel)

[iwakura@iwakura-hp290g4microtowerpc ~]$ systemctl mask tlp.service
Created symlink /etc/systemd/system/tlp.service → /dev/null.

I just tried with a usb live of Xubuntu and it has the same problem of tic - tic from the speaker…

Ok…I don’t know what…but something it worked…
I opened the pc and complete silence.

Possibly it was a jack plug that has a loose contact or was not plugged in properly?

Nope, I think that one of the commands that I put in the terminal worked not immediately but when I opened the pc.
I just don’t know what it worked…

But If the tic-tic is gone I have the others two problems jet…

How can this Ccleaner like stuff be in the official repos ?
bmenu itself is 6/7 years old, toolbox is an undocumented (ref to a non existing archive) bloatware that brings almost 10 dependencies:

Paquets (9) cmus-2.10.0-3  expac-10-5  fzf-0.34.0-1  libdiscid-0.6.2-3
            ncdu-2.2.1-1  pacui-1.14.r39.ga37e948-1
            ranger-1.9.3+428+g0b77fb8a-2  xorg-xinput-1.6.3-3  bmenu-0.20-1

Taille totale installée :  6,60 MiB

:: Procéder à l’installation ? [O/n] 

…and asks to restart once installed !!

This feels W11 like !

If the modprobe options worked to disable power management and resolve audio noise issue, the non-working set-audio-workaround.service and set-audio-workaround.sh can be removed

For a Linux live ISO, the modprobe options can be added to GRUB boot command:

  • When GRUB menu is displayed during boot press E to edit boot command

  • Find the boot command starting /boot/vmlinuz/ and add the modprobe options to the end
    snd_hda_intel.power_save=0 snd_hda_intel.power_save_controller=N

  • Use F10 OR Ctrl + X to boot live ISO

I have no interest in unrelated issues with bmenu, pkgfile and chromium

If you have a better solution please say it.


in short : twice a year, when you system is stable and you have a fresh backup

sudo paccache -rvk3
sudo pacman -Sc

For your browsers clean history, cache cookies.
For Thunderbird, set files on maildir instead of mbox.

That’s about it
And it’s not really required.