[HowTo] Make TeamViewer work after installation

:book: A republishing of my original TeamViewer thread revised to fit the forum’s new support-focused approach for people who don’t want to search the web for a solution to this very problem.

:hammer_and_wrench: Preface

A quick tip for people who need a solution fast: Having installed TeamViewer from the AUR and opening it, you may notice it doesn’t work right away. Rather than trying to over-complicate with a solution that most likely will not work, try enabling the service so the software functions as intended.

:level_slider: Turning it on

To enable TeamViewer’s remote capabilities immediately, do this:

:heavy_dollar_sign: In xdg-terminal:

systemctl start teamviewerd

To keep it on between restarts:warning: , do this:

:heavy_dollar_sign: In xdg-terminal:

systemctl enable teamviewerd

That’s it. Once you enable the daemon, TeamViewer should work immediately every subsequent boot of your Manjaro / Arch instance.

:x: Turning it off

:warning: But that’s not all! Presumably, the reason why teamviewerd isn’t enabled by default is for security concerns. After all, it does allow for remote network access, and inadvertently leaving it on, no matter how secure you think you are could be exploited. To ease security concerns, you can also do this so teamviewerd isn’t enabled on restart until otherwise:

:heavy_dollar_sign: In xdg-terminal:

systemctl disable teamviewerd

:information_source: Sources

7 Likes

Suggestion: you can start and enable the service with one command like this:

systemctl enable teamviewerd --now
2 Likes