Howto install AC600-WiFi USB Mini Adapter on Manjaro?

Hi
I have the Netgear AC600 WiFi USB Mini Wireless Adapter.

My only question is, how do I install the device on Manjaro ?

I have installed the driver package: rtl88xxau-aircrack-dkms-git, with Pamac.
Which I think is the right driver package, but correct me if I am wrong. :wink:

[philip@Acer ~]$ modprobe rtl88xxau
modprobe: FATAL: Module rtl88xxau not found in directory /lib/modules/5.8.3-2-MANJARO

    [philip@Acer ~]$ lsusb
    Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 001 Device 005: ID 04f2:b5f7 Chicony Electronics Co., Ltd HD WebCam
    Bus 001 Device 003: ID 04ca:3016 Lite-On Technology Corp. 
    Bus 001 Device 006: ID 0846:9052 NetGear, Inc. A6100 AC600 DB Wireless Adapter [Realtek RTL8811AU]
    Bus 001 Device 009: ID 045e:0780 Microsoft Corp. Comfort Curve Keyboard 3000
    Bus 001 Device 010: ID 1c4f:0034 SiGma Micro XM102K Optical Wheel Mouse
    Bus 001 Device 004: ID 2109:2813 VIA Labs, Inc. VL813 Hub
    Bus 001 Device 002: ID 2109:2813 VIA Labs, Inc. VL813 Hub
    Bus 001 Device 008: ID 04f3:0c03 Elan Microelectronics Corp. ELAN:Fingerprint
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Bus 001 Device 006: ID 0846:9052 NetGear, Inc. A6100 AC600 DB Wireless Adapter [Realtek RTL8811AU]

Does this mean that the device is installed or is it only the driver ?

Please advice next step …

Why can’t I insert links or pictures in my post ? So lame … :frowning:

The rtl88xxau-aircrack-dkms-git contains the source for the correct driver. Just don’t forget to install the headers packages for all your installed kernels.

The name of the module is 88XXau (case sensitive). Try a

sudo modprobe 88XXau

If the dkms process build was successful, you should be able to use your adapter. You might want to add the 88XXau to a conf file in /etc/modules-load.d to auto load it.
But the module should also be loaded, if you just plug the USB adapter into your system.

Why do you think a picture would be necessary in your case? Specially screenshots add not value at all. Never post screenshots of text.

3 Likes

Thx xabbu for the reply.

Well, i thougt it could be nice to insert a pic of the adapter and a link to the adapterpage on Netgear, just for reference. :slight_smile:

What command do I use to see that the adapter is in workstatus?

No sure what you mean. But you can check if the module is loaded, you can check the journal and for example

iw dev

should list the device.

Sometimes it helps to start

journalctl -f 

and then plug the device in. You should see some new messages related to your USB Wifi adapter.

And of course you should be able to select a Wifi SSID in the NM applet in your panel and connect to it.

1 Like

Heureka !

It’s working !

Now the adapter AC600 is working alright !

Thx alot xabbu for troubleshooting my problem.

Following your steps have been the only solution to the same problem, but I only get half the speed that I should, if I remove the physical wifi from the laptop, it works 100%. When disconnecting the button from the pc, everything is disconnected, it would be good if you knew any system similar to windows that allows you to choose between fixed or usb adapter, thanks.