[HowTo] get the Legacy KDE Application Menu back (prior to 5.21.1)

Difficulty: ★★☆☆☆

Plasma 5.21 brought a new version of the Application Menu (called KickOff internally).

To get the previous version back, there are two possibilities:

(Please click the below to choose which system you want to use)

Automatic Installation
  • Install ocs-url from the Arch User Repository, from terminal run pamac build ocs-url (or use your preferred AUR helper)

  • Go to the KDE Store page here.

  • Click the Install button on top right corner, and click the kickoff plasmoid file

  • In the popup that appears, click Install and it will ask to open the link with the ocs-url tool, accept and confirm the installation.

  • Right click the Application Menu icon in your Panel/Taskbar, select Show Alternatives, and you should see Legacy Application Launcher (if your OS language is English, otherwise, look at the preview image to differentiate the old from the new one). Select it, reconfigure your icons, and you’re done.

Manual Installation

Good! You know what you’re doing and want to do it exactly the way you want and know how to do it! :+1:

  • Go to the KDE Store page here.

  • Click the Download button on top right corner, and click the kickoff plasmoid file

  • *TO BE DETERMINED: use terminal with proper command to install the plasmoid locally.
    This should be something along these lines, from terminal, but I’m not sure:
    plasmapkg2 -i kickoff-legacy-x.x.x.plasmoid
    please someone confirm the correct procedure

  • Right click the Application Menu icon in your Panel/Taskbar, select Show Alternatives, And you should see Legacy Application Launcher (if your OS language is English, otherwise, look at the preview image to differentiate the old from the new one). Select it, reconfigure your icons, and you’re done.

6 Likes

Alternative ways to get the legacy Kickoff menu:

  • Use the “Download new Plasma widgets” window;

  • In AUR, you can get the kickoff-legacy-git package.

1 Like

i’ve resorted to the legacy-kickoff myself. only issue is i’m having problem setting “super” as its hotkey in its settings. when try to set it, it is expecting super+[key] combo and not “super” in-itself

Set it to ALT+F1

It shouldn’t have changed your previous shortcuts though, but try what I suggest and retry your “Super” key then.

Also have a look inside Manjaro Settings → Shortcuts → Plasma → Enable Application Launcher Graphic Component and set a shortcut there maybe too (same ALT+F1)?