[HowTo] Fix no Audio and Microphone (Realtek ALC711-CG) issues after installing Manjaro

After installing Manjaro (Kernel 5.10.89-1-MANJARO), my Audio and Microphone were not working and just showing Dummy Devices.

Thanks to XPS 9700 Sound and Wifi linux510 - #16 by Mitch I was able to fix it. High Five to Mitch for this post!

To ensure others will find it easier, I wrote this HowTo. Here are the steps to copy & paste.

1. Check the following files:


ls -la /etc/modprobe.d/alsa.conf

and alsa-base.conf

ls -la /etc/modprobe.d/alsa-base.conf

In case they exist, just rename them (I don’t like deleting system files, but feel free to do it at own risk)

sudo mv /etc/modprobe.d/alsa.conf /etc/modprobe.d/alsa.conf.bck
sudo mv /etc/modprobe.d/alsa-base.conf /etc/modprobe.d/alsa-base.conf.bck

2. Reinstall the sound drivers:

sudo pacman -S pulseaudio sof-firmware alsa alsa-ucm-conf

3. Reboot:

1 Like

I think your title is too general and doesn’t match these specific information. You probably should rethink the thread title to match particularly these instructions, which probably are for a specific case (specific to this laptop model/series?)


Done :slight_smile:

I don’t think you need sudo there.

The linked comment from 12 months ago is no longer relevant. These systems did need a modprobe option to disable the internal digital microphone array, similar to other systems with Sound Open Firmware issues, but most of the issues have been resolved

Issues for this model were first reported on the old forum in July 2020
Dell XPS 17 9700 Audio Issues - SOF / SoundWire - archived.forum.manjaro
And there was a recent issue with /usr/share/alsa/ucm2/sof-soundwire/soundwire.conf
Dell xps 9710 (2021) no audio

Users installing Manjaro with the latest ISO should only need to do one thing to get audio working:

Dell XPS 17 (9700) - ArchWiki
This laptop requires firmware from the sof-firmware package in order for the internal sound card to work

8086-06c8-1028-098f - Intel Comet Lake PCH cAVS | linux-hardware.org

For users who may have added modprobe options in the past I would suggest using this command to check for any ALSA options

grep snd /etc/modprobe.d/*.conf

Thank you for the feedback. It seems hw-probe is not available. Tried to install it, on both ways. Hasn’t worked; “package not found”. However, was just a quick try, maybe there is another source. The existing post has at least worked for me, but I will spend some time for investigating the modprobe thing.

Hardware scans can be useful for comparing to similar hardware but alsa-info.sh script can gather more ALSA information for troubleshooting audio

Appimage, Flatpak and Snap packages for hw-probe do not show ALSA data, so building AUR package is the only way to share audio data to linux-hardware.org