[HowTo] Booting manjaro iso directly with grub

That is not what I’m describing. I want live session to recognize where proper home folder is on a hard drive and work off of that. It has nothing to do with USB sticks or portability.
You can build your own iso whenever you want.

So, a bit like frugal install? If I’m understanding correctly, you specifically want to avoid persistence with the system and only have persistent /home? That seems like pretty reasonable use case.

Using persistent iso would make mounting the /home much easier, but you can probably do it with a properly configured iso-profile too. Just put a suitable fstab to the live-overlay, set your user in profile.conf and off to the races you go. You will probably want to include manjaro-tools-iso in the Packages-Desktop and store your iso files on your /home partition.

1 Like

Yup, I did just that - included fstab in the live overlay and it works very well. I’ve built a very basic iso for now to see if it will work, now I have to improve it and see if it can be used as a daily driver :wink:

Buildiso has some kind of persistence:
-m Set SquashFS image mode to persistence
I don’t know how to use it though. It would make the job a lot easier for sure.

1 Like

I don’t think that option actually works. For actually working persistence you light need ALMA like @Fabby suggested

But, now that you have a working frugal manjaro installation, would you like to write a tutorial for it? I’m sure it would be much appreciated.

I probably will in the near future. For now there’s still some stuff I have to figure out and test.
Also if ALMA could support compression and copytoram it might be a better idea.

1 Like

Forgive me: I’m not used to users who come here asking questions. I originally thought you were posting an XY problem, but:

It seems that you’re someone who will be answering questions here…

And even write a tutorial pretty soon!

:+1: :wink:

thank you kind sir, I will try this out and post results, this is great.

or not

Last Post 5 Oct
Seen 7 Oct

:rofl:

Sad but classical hit and run.

1 Like

Would this work for any iso of any distribution?

Mostly yes, but the exact boot entries vary. But in principle, it works. For an example, Fedora entry can look like this:

menuentry 'Fedora Live' --class os --class gnu-linux --class gnu --class os --group group_main {
                set isofile="/live/Fedora-Workstation-Live-x86_64-32-1.6.iso"

         insmod ext2
         insmod loopback
         insmod iso9660      
                loopback loop (hd0,msdos1)$isofile      
                search --no-floppy --fs-uuid --set=root 3b87d941-8ee7-4312-98fc-1f26828d62ab                            
                linux (loop)/isolinux/vmlinuz boot=live fromiso=/dev/sda1/$isofile noconfig=sudo username=root hostname=fedora
                initrd (loop)/isolinux/initrd.img
}

And Kali like this:

menuentry 'Kali Linux Live' --class os --class gnu-linux --class gnu --class os --group group_main {
                set isofile="/live/kali-linux-2020.2-live-i386.iso"

         insmod ext2
         insmod loopback
         insmod iso9660      
                loopback loop (hd0,msdos1)$isofile      
                search --no-floppy --fs-uuid --set=root 3b87d941-8ee7-4312-98fc-1f26828d62ab                            
                linux (loop)/live/vmlinuz boot=live fromiso=/dev/sda1/$isofile noconfig=sudo username=root hostname=kalilinux
                initrd (loop)/live/initrd.img
}
2 Likes

Ok thanks. :+1:

Instead of:

you should use the grub environment variable $root like this:

loopback loop ($root)$ISOFile

as that is more hardware independent (and most people nowadays aren’t familiar with the old-style hd0 terminology any more as we’ve all got /dev/sdY SATA / SCSI disks now instead of the old MFM/RLL /dev/hdY ones…) ¹

:slight_smile:

Note 1: You old fart! :joy: :grin:

1 Like

works great, thank you so much

I can’t start, I get a message that says:
error: invalid file name `’.

error: disk `loop’ not found.
error: you need to load the kernel first.

Double-check the file location and file name in

set isofile="/miso/manjaro-gnome-20.1-stable-x86_64.iso"

and adapt to your specific system settings.

:+1:

The file location and file name are correct.

Are you using btrfs subvolumes?

No i use xfs.

Can you post your custom.conf?