[HowTo] Bluetooth headphones paired, but no sound after a while

Hi,
I’m not running manjaro but i’m running arch, and the issue I had was that my PC would keep playing through the integrated speakers even though my bluetooth speaker was connected.

While your fix worked, the problem is that now my speakers don’t work anymore ! I reverted the changes and it’s back to normal now.

Any idea why it does this ? Any potential solution ?

Excellent! I’ve been wrestling with this since making the switch to Manjaro several months ago. This got my JBL Live300TWS buds working quite well. First run through it wasn’t working at all … but that was a keystroke error on my part. Now it’s great.

Thanks very much.

I think this finally solved my problem!!! Thank you so much!!!

I’m pretty happy with that - I had been thinking about figuring out a way to make the sound output switch automatically upon connecting bluetooth headsets. Didn’t think it would effectively be a one-liner - thanks a bunch.

Didn’t help buddy. Could you please look into my issue??

A post was split to a new topic: How do I use nano?

The latest manjaro system, did step by step as this, didn’t help. Any updates?

If the bluetooth connection does not drop when pavucontrol is kept open
the only thing a user should need to do to resolve this is remove module-suspend-on-idle

pacmd unload-module module-suspend-on-idle

and disable loading of module-suspend-on-idle for future desktop sessions

sudo sed -i '/load-module module-suspend-on-idle/s/^/#/' ~/.config/pulse/default.pa

If PulseAudio restart is needed, Manjaro users should use this command

systemctl --user restart pulseaudio

Using pulseaudio command with -k or --kill and --start options is only suitable for some old-school Arch users running PulseAudio without systemd socket and service

.ifexists and .endif form an important failsafe for loading Bluetooth modules
if they are commented out as suggested, nothing will happen immediately
But at some future time PulseAudio may fail to load one of the Bluetooth modules and the whole sound server will fail to start,
and user may not recall this reconfiguration change when the failure occurs

PulseAudio module module-switch-on-connect is not necessary for preventing suspension of Bluetooth sink
Users should consider the warning about use of this module:

PulseAudio/Documentation/module-switch-on-connect
This module is not loaded by default, beacuse it’s a bit too aggressive. If the user sets the default sink or source manually, that choice gets forgotten when plugging in a new sound card, which can be undesirable

If a user wants to try this module to see if suits their needs, the extra module can be added as a custom configuration in home folder

cat <<EOT > ~/.config/pulse/default.pa
.include /etc/pulse/default.pa
load-module module-switch-on-connect ignore_virtual=no
EOT

and restart PulseAudio (see systemctl command above) or reboot system

If the module is found to be undesirable, delete the custom configuration and unload the module from current session

rm ~/.config/pulse/default.pa; pacmd unload-module module-switch-on-connect