How to use the modesetting driver?

Note: If you have an Intel GPU, make sure you are not using xf86-video-intel with Cinnamon as it may freeze at random times otherwise, but you can still move the mouse. Use the modesetting(4) driver instead by removing xf86-video-intel (KDE also recommends this).

Now I am using KDE and meeting similar problems here, so I want to switch to modesetting, but I searched in Archwiki and found no instructions on installation and settings. Could someone help me?

1 Like

The modesetting driver comes with Xorg. Just uninstall xf86-video-intel.

1 Like

Thanks! I found that it will cause some icons on the taskbar fail to display, how to fix it?

Can you post the output of the commands below:
sudo mhwd -li
sudo inxi -G

(base) [firestar@FIRESTAR ~]$ sudo mhwd -li
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!
(base) [firestar@FIRESTAR ~]$ sudo inxi -G
Graphics:  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel 
           Display: server: X.Org 1.20.10 driver: loaded: modesetting s-res: 2736x1824 
           OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.3.4 

It mysteriously appeared although I did nothing:

But sometimes the welcome screen (splashscreen) will show like this:

which the proper screen is like this: (Miku will be higher)

Hey @Firestar
Looks like you are already using modesetting. I think you’re dealing with 2 separate things: 1. glitchy desktop objects and 2. improper display resolution for your custom desktop.

Things to try, in my opinion:

  1. See if switching the driver to video-modesetting makes any difference. The easiest way to do this is on the GUI (Manjaro Settings → Hardware Configuration)

  2. You might want to play around with your KDE desktop resolution. If you’re not able to achieve the desired outcome with any of the predefined resolution values in KDE, you might want to create a custom mode using a combination of cvt / xrandr and making it persistent via xorg.conf. The link below shows how to do this (from Arch Wiki):

Hope that helps!

The missing icons might be an issue with your theme. I don’t think the breath themes were updated with all icons required for Plasma 5.21. Try the Breeze Plasma theme.

Both theme lost icons for Electron and SAOImageDS9, many icons hopping with the cursor when I open an app it becomes the default “triangle in a box” icon.

video-linux displays better than video-modesetting

On video-modesetting, the windows and icons displayed in a smaller mode (some of the icons are different) although I have a x200% screen. Yakuake also displays like this:

On video-linux, the splashscreen issue has fixed. But on video-modesetting, no.

But video-linux crashed this morning.

It makes my computer broke. It can only use the CLI now

You should start explaining what steps you have done so far.

See if you can get into your desktop by switching TTYs or starting it manually.

Modes created with Xrandr are not persistent unless you make them so in a configuration file. Rolling back the configuration changes and restarting should be good.

I can switch tty. I tried to configure them in MHWD (like reinstalling video-modesetting and video-linux) but failed. Sorry I have deleted and reinstalled Manjaro.

I remember I have done these:

cvt 2736 1824
xrandr --newmode "2736x1824_60.00" ...... -hsync +vsync
xrandr --addmode eGP-1 2736x1824_60.00
xrandr --output eGP-1 --mode 2736x1824 60.00

Current major issue is this Yakuake thing


in “localization”


in “Keyboard settings”

What is important is that they cannot be tweaked by system-settings


It seems going back to 100% and go to 200% (reboot twice) can fit these problem.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.