How to use Brother scanner via wifi?

I have multifunctional device Brother MFC J4620DW.

I installed drivers for printer from AUR and it works great. However, I couldn’t figure out how to use scanner via wifi?

I installed from AUR:
brscan-skey
brscan4

On the documentation page for this device I can see:

https://support.brother.com/g/b/faqend.aspx?c=gb&lang=en&prod=mfcj4620dw_us_eu_as&ftype3=100258&faqid=faq00100714_000

In the terminal window, type brscan-skey and then press the Enter key.

The issue is, when I do this, I get:

bash: brscan-skey: no such command

So how brscan-skey can be installed (I can see all relevant files and folders in /opt/brother/scanner/) and then not work? What am I missing?

Is the directory with the executable in your $PATH? If not, then you have to prepend the name of the executable on the command line with the path to the executable, e.g… :arrow_down:

/opt/brother/scanner/brscan-skey

This is equally true if your current working directory is the directory with the executable, because the current working directory is not in the $PATH by default ─ and it shouldn’t be. However, in both cases, you need not provide an absolute path to the executable; a relative path will work just as well, e.g… :arrow_down:

./brscan-skey

… if your current working directory is the directory with the executable.

Can you translate it to noob? I have no idea what you just wrote.
What is my $PATH ? Where do I find it?

I also tried to execute the file directly, but nothing happened:

/opt/brother/scanner/brscan-skey/brscan-skey

The $PATH is the colon-separated list of directories in which the shell will look for commands that are not internal to the shell itself, or in other words, executables. You can see what directories are in your $PATH by issuing the command… :arrow_down:

echo $PATH

Did it not produce any output at all? What is that command supposed to do?

Edit: According to the page at Brother’s website that you linked to above… :arrow_down:

2.1 The scanned data destination directory
The scanned data is saved in the “brscan” directory in each user’s home directory.

Maybe you can try to install the ‘sane-airscan’ package.

According to the GitHub documentation :

This backend implements both protocols, choosing automatically between them. It was successfully tested with many devices from Brother , Canon , Dell , Kyocera , Lexmark , Epson , HP , Panasonic , Ricoh , Samsung and Xerox both in WSD and eSCL modes.

This is the package i use for my EPSON network (wifi) scanner, and it works fine !

1 Like

You use a scanning program that interface your scanner. I have a MFC-J4710DW and scanning with the preinstalled “Document Scanner” program (I’m using GNOME edition) works just fine.

Did you configure your scanner first. After installing drivers, if system doesn’t see it maybe try configure it in terminal:

Add network scanner entry
Command : brsaneconfig4 -a name=(name your device) model=(model name) ip=xx.xx.xx.xx

Confirm network scanner entry
Command : brsaneconfig4 -q | grep (name of your device)

Open a scanner application and try a test scan.

If i remember correctly, “Scan key tool” (brscan-skey), is only additional tool for scanning direct to email and such. I don’t have Brother printer anymore ( and i had different model), but hope it will help.

2 Likes

The above syntax works for me, i.e:

[me@Probook-450 ~]$  sudo brsaneconfig4 -a name=Brother model=MFC-9970CDW ip=192.168.0.13     

Test it with scanimage:

scanimage --format=jpeg >image.jpg    

And install xsane if you want an human interface.

2 Likes

Sorry to hijack the thread. I have Epsom bx305fw all in one with same issue. I’ve tried every scan software available, they see the scanner (detect it as the wrong model though) but always fail to connect to the scanner when I try to scan.

WOW! That worked!

I used:

sudo brsaneconfig4 -a name=Brother model=MFC-J4620DW ip=192.168.1.24

where IP is the address of the scanner (visible in router).

I installed xsane, opened it, it saw the new configuration and was able to interact with it. I tested it and scan through wifi works!

I have this device for years and till now had to use USB to make it work but it wasn’t convinient. Now it works as it should, finally! :smiley:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.