How to update WIFI Driver?

I’m running Manjaro 5.15.10 KDE 5.27.7, kernel 6.4.9-1 on a home built PC. I just updated my internet to fiber (500mbps) with an EERO mesh system. The speed at the main unit is around 400 mbps, with 585 mbps at the unit. My problem lies with the PC where I’m getting 156 mbps download and 288 mbps upload (doesn’t make sense) EERO went through a bunch of diagnostics and suggested maybe the WIFI driver needs to be updated. It’s an ASUS PCE-AX3000.

I just let the system do it’s updates (generic), but as a slightly above novice, I’m not sure how to update the driver. Any suggestions would be greatly appreciated


It appears you listed 2 kernels.

Otherwise manjaro doesnt really have ‘versions’ besides the ISO releases.
As a rolling release distro … you are either up to date … or not.

Maybe just provide the output of

inxi -Fazy

Probably not.
In any case it wouldnt be separate from the rest of system updates.
(EERO probably had no idea what they were talking about and spouted some generic windoze bs)
In any case a good place to start would be system info. See above.

1 Like

Here’s what appears under inxi -Fazy:

Kernel: 6.4.9-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.4-x86_64
    root=UUID=0ab6956b-5869-4ca1-834c-5c1dc78a1274 rw quiet
    root=/dev/mapper/luks-ee3e938b-8d2f-4406-bd30-2c91fe019177 splash
  Desktop: KDE Plasma v: 5.27.7 tk: Qt v: 5.15.10 info: latte-dock
    wm: kwin_x11 vt: 2 dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: Micro-Star product: MS-7C02 v: 1.0
    serial: <superuser required>
  Mobo: Micro-Star model: B450 TOMAHAWK MAX (MS-7C02) v: 1.0
    serial: <superuser required> UEFI-[Legacy]: American Megatrends v: 3.70
    date: 06/09/2020
  Device-1: hidpp_battery_0 model: Logitech MX Keys Wireless Keyboard
    serial: <filter> charge: 100% (should be ignored) rechargeable: yes
    status: discharging
  Info: model: AMD Ryzen 5 2600 bits: 64 type: MT MCP arch: Zen+ gen: 2
    level: v3 note: check built: 2018-21 process: GF 12nm family: 0x17 (23)
    model-id: 8 stepping: 2 microcode: 0x800820D
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 576 KiB desc: d-6x32 KiB; i-6x64 KiB L2: 3 MiB desc: 6x512 KiB L3: 16 MiB
    desc: 2x8 MiB
  Speed (MHz): avg: 1647 high: 2800 min/max: 1550/3400 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1550 2: 1550
    3: 1550 4: 1550 5: 2800 6: 1475 7: 1550 8: 1550 9: 1550 10: 1550 11: 1550
    12: 1550 bogomips: 81615
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT vulnerable
  Type: spec_rstack_overflow mitigation: safe RET
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    disabled, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
    vendor: XFX Pine driver: amdgpu v: kernel arch: GCN-4 code: Arctic Islands
    process: GF 14nm built: 2016-20 pcie: gen: 3 speed: 8 GT/s lanes: 16 ports:
    active: HDMI-A-1 empty: DP-1, DP-2, DP-3, DVI-D-1 bus-ID: 29:00.0
    chip-ID: 1002:67df class-ID: 0300 temp: 52.0 C
  Device-2: Logitech BRIO 4K Stream Edition
    driver: hid-generic,snd-usb-audio,usbhid,uvcvideo type: USB rev: 3.1
    speed: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 bus-ID: 4-1:2 chip-ID: 046d:086b
    class-ID: 0300 serial: <filter>
  Display: x11 server: X.Org v: 21.1.8 compositor: kwin_x11 driver: X:
    loaded: amdgpu unloaded: modesetting alternate: fbdev,vesa dri: radeonsi
    gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x2160 s-dpi: 96 s-size: 1016x571mm (40.00x22.48")
    s-diag: 1165mm (45.88") monitors: <missing: xrandr>
  Monitor-1: HDMI-A-1 model: Samsung serial: <filter> built: 2022
    res: 3840x2160 dpi: 103 gamma: 1.2 size: 1872x1053mm (73.7x41.46")
    diag: 1093mm (43") ratio: 16:9 modes: max: 3840x2160 min: 720x400
  API: OpenGL v: 4.6 Mesa 23.1.5 renderer: AMD Radeon RX 580 Series
    (polaris10 LLVM 15.0.7 DRM 3.52 6.4.9-1-MANJARO) direct-render: Yes
  Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
    vendor: XFX Pine driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s
    lanes: 16 bus-ID: 29:00.1 chip-ID: 1002:aaf0 class-ID: 0403
  Device-2: AMD Family 17h HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 2b:00.3 chip-ID: 1022:1457 class-ID: 0403
  Device-3: Logitech BRIO 4K Stream Edition
    driver: hid-generic,snd-usb-audio,usbhid,uvcvideo type: USB rev: 3.1
    speed: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 bus-ID: 4-1:2 chip-ID: 046d:086b
    class-ID: 0300 serial: <filter>
  API: ALSA v: k6.4.9-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.77 status: off with: wireplumber status: active
    tools: pw-cli,wpctl
  Server-3: PulseAudio v: 16.1 status: active with: pulseaudio-alsa
    type: plugin tools: pacat,pactl
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: f000 bus-ID: 22:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp34s0 state: down mac: <filter>
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
    speed: 5 GT/s lanes: 1 bus-ID: 28:00.0 chip-ID: 8086:2723 class-ID: 0280
  IF: wlp40s0 state: up mac: <filter>
  Device-1: Intel AX200 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-10:7 chip-ID: 8087:0029
    class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 465.76 GiB used: 25.11 GiB (5.4%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Corsair model: Force MP600
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: EGFM11.3 temp: 43.9 C
    scheme: MBR
  ID-1: / raw-size: 465.76 GiB size: 457.37 GiB (98.20%) used: 25.11 GiB (5.5%)
    fs: ext4 dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-ee3e938b-8d2f-4406-bd30-2c91fe019177
  Alert: No swap data was found.
  System Temperatures: cpu: 49.6 C mobo: N/A gpu: amdgpu temp: 53.0 C
  Fan Speeds (rpm): N/A gpu: amdgpu fan: 768
  Processes: 344 Uptime: 1h 18m wakeups: 8 Memory: total: 32 GiB
  available: 31.29 GiB used: 2.66 GiB (8.5%) Init: systemd v: 253
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 15.0.7
  Packages: 1252 pm: pacman pkgs: 1241 libs: 379 tools: pamac pm: flatpak
  pkgs: 11 Shell: Zsh v: 5.9 default: Bash v: 5.1.16 running-in: konsole
  inxi: 3.3.29

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

I’m guessing this is the device in question?
iwlwifi is a kernel driver … nothing extra to update.

And thats your kernel. 6.5 is also available if you want to test that.

Speaking of tests … how are you measuring your up/down speed ?

A test for down might be something like:

wget -O /dev/null

( note you can choose any instance listed here: )

1 Like

I used )OOKLA. Kernal 6.5 is available, but experimental as of yet. I have found it wise, especially considering my lack of expertise, to download experimental programs , Here are the results requested:

–2023-08-31 16:30:24--
Resolving (…, 2600:3c01::f03c:91ff:feae:68d
Connecting to (||:80… connected.
HTTP request sent, awaiting response… 200 OK
Length: 1048576000 (1000M) [application/octet-stream]
Saving to: ‘/dev/null’

/dev/null 100%[=========================================>] 1000M 29.5MB/s in 41s

2023-08-31 16:31:05 (24.2 MB/s) - ‘/dev/null’ saved [1048576000/1048576000

BTW, this is the PC in question

Correction, wise to NOT download experimentals

OK, so that translates to 193.6 Mbps.
(Note Mb vs MB)

And you get better speed at the primary router when compared to the extra node(s) ?

This almost certainly has to do with the network configuration.

Are you sure you have not put your device into ‘repeater’ mode?
This was more common before mesh (and is still used today) … its general function looked exactly like you describe - it would extend the coverage by ‘repating’ the signal … but everything under that repeated signal would get half the speed.

I don’t see anything in the EERO settings that indicates “repeater” mode. I did notice however that the IPv6 was off, so I activated it, which increased the speed to 221Mb down, but the upload speed is faster, 287Mb which make no sense to me.

My first suggestion for the wireless module options would be:


options iwlwifi 11n_disable=8

(reload the module, or reboot)

But still I am not sure the wireless card or its driver is really the issue … do other devices not show the same results ?

1 Like

If I run the speedtest on my phone, from the same location, it is significantly faster. As far as your suggestion is concerned, a reminder, I’m kind of new to this game. How do I go about implementing your suggestion, and what will that do?

You would create the file with those contents.
Or you could run this command which would do that:

printf 'options iwlwifi 11n_disable=8' | sudo tee /etc/modprobe.d/iwlwifi.conf

Despite the name, what it would do is enable antenna aggregation, which often provides a performance boost.


A much better test would be, if possible, to move the PC closer to the router and see if the speed improves. Or even try just rotating the PC so that the wifi antenna has a clear sight of the router. It might be something as simple as the wifi signal being partially blocked by a big lump of metal (your PC case).

That actually slowed it down a bit. How do I put it back to where it was? And, any ideas as to why the upload is significantly faster than the download?

It’s a PCI card and the antennas are on the outside of the case. I can’t move it closer to the router, but it’s no more than 15-20’ from the satellite EERO mesh unit

If you mean the option above then you can remove the file:

sudo rm /etc/modprobe.d/iwlwifi.conf