How to turn off the Wi-Fi power-saving mode?

I am having an issue with my dell xps 15 9520 in term of the Wi-Fi speed. I’m getting 3 mbps whereas my full internet speed is 90 mbps. The connection works as expected with a cable. I had the same issue on other distros too, but on Pop OS there is this fix, where you set wifi.powersave = 2 in /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf.

Is there a similar fix for Manjaro?

EDIT:

I also added these lines in /etc/modprobe.d/wifi.conf

options iwlwifi swcrypto=1 # enables software crypto
options iwlwifi power_save=0 # disables power management
options iwlwifi 11n_disable=1 # disables 11n connections
options iwlwifi disable_11ac=1 # disables 11ac connections
options iwlwifi disable_11ax=1 # disables 11ax connections

It increased the download speed up to 20 mbps out of 90. The upload speed is 30.

its the same in manjaro, create the file:
kate /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
put there the line:
wifi.powersave = 2
save the file and reboot

I already did that, but it had almost no effect. The speed is currently at 7 mbps for Download and around 30 for Upload. On Pop OS that solved the issue immediately.

so try with different kernels: 5.15, 5.10, 5.19 and see if that helps…if not provide system info:
inxi -Faz

Note that the name of the driver I install on Windows is Intel AX211 and Killer 1690/1650/1675 Wi-Fi Controller Driver. The model of the Wi-Fi is Intel® Killer™ Wi-Fi 6 1675 (AX211) 2x2

System:
  Kernel: 5.19.7-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.19-x86_64
    root=UUID=29272a27-bb9e-43fa-ab8f-d5b07a312969 rw quiet apparmor=1
    security=apparmor resume=UUID=bab99932-9727-4475-8057-e32101574605
    udev.log_priority=3
  Desktop: KDE Plasma v: 5.25.5 tk: Qt v: 5.15.5 wm: kwin_x11 vt: 1
    dm: SDDM Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Laptop System: Dell product: XPS 15 9520 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Dell model: 0F6K9V v: A00 serial: <superuser required> UEFI: Dell
    v: 1.3.0 date: 04/20/2022
Battery:
  ID-1: BAT0 charge: 75.8 Wh (91.7%) condition: 82.7/84.3 Wh (98.1%)
    volts: 12.1 min: 11.4 model: SMP DELL 70N2F95 type: Li-poly
    serial: <filter> status: discharging
CPU:
  Info: model: 12th Gen Intel Core i9-12900HK bits: 64 type: MST AMCP
    arch: Alder Lake gen: core 12 level: v3 built: 2021+ process: Intel 7 (10nm
    ESF) family: 6 model-id: 0x9A (154) stepping: 3 microcode: 0x421
  Topology: cpus: 1x cores: 14 mt: 6 tpc: 2 st: 8 threads: 20 smt: enabled
    cache: L1: 1.2 MiB desc: d-8x32 KiB, 6x48 KiB; i-6x32 KiB, 8x64 KiB
    L2: 11.5 MiB desc: 6x1.2 MiB, 2x2 MiB L3: 24 MiB desc: 1x24 MiB
  Speed (MHz): avg: 2544 high: 2900 min/max: 400/5000:3800 scaling:
    driver: intel_pstate governor: powersave cores: 1: 509 2: 2900 3: 2900
    4: 2900 5: 2900 6: 2900 7: 525 8: 2900 9: 2900 10: 2900 11: 2900 12: 2900
    13: 2900 14: 557 15: 2900 16: 2900 17: 2900 18: 2900 19: 2900 20: 2900
    bogomips: 116780
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
    filling, PBRSB-eIBRS: SW sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel Alder Lake-P Integrated Graphics vendor: Dell driver: i915
    v: kernel arch: Gen-12.2 process: Intel 10nm built: 2021-22+ ports:
    active: eDP-1 empty: DP-1, DP-2, DP-3, DP-4, HDMI-A-1 bus-ID: 00:02.0
    chip-ID: 8086:46a6 class-ID: 0300
  Device-2: NVIDIA GA107M [GeForce RTX 3050 Ti Mobile] vendor: Dell
    driver: N/A alternate: nouveau non-free: 515.xx+ status: current (as of
    2022-08) arch: Ampere code: GAxxx process: TSMC n7 (7nm) built: 2020-22
    pcie: gen: 4 speed: 16 GT/s lanes: 8 link-max: lanes: 16 bus-ID: 01:00.0
    chip-ID: 10de:25a0 class-ID: 0302
  Device-3: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 3-6:3 chip-ID: 0bda:551c class-ID: fe01 serial: <filter>
  Display: x11 server: X.Org v: 21.1.4 compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,vesa gpu: i915 display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1920x1200 s-dpi: 96 s-size: 507x317mm (19.96x12.48")
    s-diag: 598mm (23.54")
  Monitor-1: eDP-1 model: Samsung 0x414d built: 2020 res: 1920x1200 hz: 60
    dpi: 145 gamma: 1.2 size: 336x210mm (13.23x8.27") diag: 396mm (15.6")
    ratio: 16:10 modes: 3456x2160
  OpenGL: renderer: Mesa Intel Graphics (ADL GT2) v: 4.6 Mesa 22.1.7
    direct render: Yes
Audio:
  Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: Dell
    driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_tgl
    bus-ID: 00:1f.3 chip-ID: 8086:51c8 class-ID: 0403
  Sound Server-1: ALSA v: k5.19.7-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.57 running: yes
Network:
  Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:51f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  Device-2: ASIX AX88179 Gigabit Ethernet type: USB driver: ax88179_178a
    bus-ID: 2-1.2:3 chip-ID: 0b95:1790 class-ID: ff00 serial: <filter>
  IF: enp0s13f0u1u2 state: up speed: 100 Mbps duplex: full mac: <filter>
Bluetooth:
  Device-1: Intel type: USB driver: btusb v: 0.8 bus-ID: 3-10:6
    chip-ID: 8087:0033 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
Drives:
  Local Storage: total: 953.87 GiB used: 13.23 GiB (1.4%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: PM9A1 NVMe
    1024GB size: 953.87 GiB block-size: physical: 512 B logical: 512 B
    speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter> rev: 36308229
    temp: 38.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 919.44 GiB size: 903.93 GiB (98.31%) used: 13.23 GiB
    (1.5%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 312 KiB
    (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 34.13 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
Sensors:
  Message: No sensor data found. Is lm-sensors configured?
Info:
  Processes: 362 Uptime: 1m wakeups: 39 Memory: 31.03 GiB used: 2.37 GiB
  (7.6%) Init: systemd v: 251 default: graphical tool: systemctl Compilers:
  gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman pkgs: 1264 libs: 334
  tools: pamac pm: flatpak pkgs: 0 Shell: Zsh v: 5.9 default: Bash v: 5.1.16
  running-in: konsole inxi: 3.3.21

i noticed you dont have any driver for nvidia:

is that on purpose?

so lets do some testing, remove all of the parameters from the wifi.conf:

and replace them with only this one:
options iwlwifi.disable_11ax=true
save the file, and reboot

The Nvidia driver was N/A because I have changed the kernel. Now I changed it back to linux515, and the driver is back to normal.

After the changes you recommended, the internet speed is 10/30 for download/upload out of 90.

Graphics:
  Device-1: Intel Alder Lake-P Integrated Graphics vendor: Dell driver: i915
    v: kernel arch: Gen-12.2 process: Intel 10nm built: 2021-22+ ports:
    active: eDP-1 empty: DP-1, DP-2, DP-3, DP-4, HDMI-A-1 bus-ID: 00:02.0
    chip-ID: 8086:46a6 class-ID: 0300
  Device-2: NVIDIA GA107M [GeForce RTX 3050 Ti Mobile] vendor: Dell
    driver: nvidia v: 515.65.01 alternate: nouveau,nvidia_drm non-free: 515.xx+
    status: current (as of 2022-08) arch: Ampere code: GAxxx process: TSMC n7
    (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 8 link-max:
    lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:25a0 class-ID: 0302
  Device-3: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 3-6:3 chip-ID: 0bda:551c class-ID: fe01 serial: <filter>
  Display: x11 server: X.Org v: 21.1.4 compositor: kwin_x11 driver: X:
    loaded: modesetting,nvidia alternate: fbdev,nouveau,nv,vesa gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1200 s-dpi: 96 s-size: 507x317mm (19.96x12.48")
    s-diag: 598mm (23.54")
  Monitor-1: eDP-1 model: Samsung 0x414d built: 2020 res: 1920x1200 hz: 60
    dpi: 145 gamma: 1.2 size: 336x210mm (13.23x8.27") diag: 396mm (15.6")
    ratio: 16:10 modes: 3456x2160
  OpenGL: renderer: Mesa Intel Graphics (ADL GT2) v: 4.6 Mesa 22.1.7
    direct render: Yes

Hello @tmargary :wink:

Maybe have look at this thread: Slow wifi with Intel AX211 on Arch compared to Windows / Networking, Server, and Protection / Arch Linux Forums At least it could be some sort Router Issue in combination with that wifi card.

I’m sure it’s not a hardware issue because Pop OS works just fine. Dell has official driver support from Ubuntu

it was probably n/a because you are affected with the ibt arch but and you need to set this kernel parameter: ibt=off
open this file:
/etc/default/grub
and inside this line: GRUB_CMDLINE_LINUX_DEFAULT inside the quotes add this parameter:
ibt=off
dont remove anything, just add it to existing parameters, save the file, update grub:
sudo update-grub
now you should be able to use nvidia also on newer kernels…

add this another option to your wifi config:
options iwlwifi.disable_11ac=true
save the file, reboot

The speed after this config: 6/11 for download/upload out of 90. At this point I’ll probably give up and go with Pop OS

you can try as a last option to add again these options:
options iwlwifi 11n_disable=1
options iwlwifi swcrypto=1
save it, and reboot

if it doesnt work, remove the wifi.conf, and uninstall this package: iwd, reboot and test…
https://bbs.archlinux.org/viewtopic.php?id=272603&p=2

What if there is no iwd installed in the first place?

than it doesnt apply to you… found on arch wiki some options that could help:
options iwlwifi 11n_disable=8
options iwlwifi bt_coex_active=0
you can try them, you have nothing lose

Still no success. But thanks for your support a lot. My best bet is that it’s a kernel issue and might resolve itself in the future.

thats a possibility, but since it works normally on popos, maybe its a manjaro/arch thing…