How to temporarily disable zsh manjaro customizations and be able to use `PROMPT`?

I like the p10k, but sometimes I need to temporarily turn it off (for just one zsh instance) to copy shell output without any special stuff (for docs or sharing in chat, meaning without fancy unicode characters, user name and so on).

These two aliases used to work before (on old PC, probably like 5 years old config, I am guessing without p10k):

alias example-prompt='PROMPT="[%?] %1d %(!.#.$) "'
alias terse-prompt='PROMPT="%(!.#.$) "'

When I try them now, they do nothing. PROMPT is totally ignored.

Unless I’m missing something, I think you need to rewrite your prompts.

PROMPT="[%?] %1d %(!.#.$) "                                                                                                                                                                                              
zsh: event not found: .#

PROMPT="%(!.#.$) "
zsh: event not found: .#


I think it behaves a bit differently, when it’s in alias:


(the red green arrow in next prompt means it didn’t end with error)

You’re right, I’ve never changed the prompt in an alias before. Neither do I currently understand exactly what each prompt is doing, it’s been too long I need a refresher.

It works for me (assuming this is what it’s meant to look like) but I have a custom config, and I don’t use powerlevel.


[0] testy $

I may be missing something, but if you only need a simpler shell as a one off every so often would it not be easier just type bash to temporarily switch to a bash shell?


but if you only need a simpler shell as a one off every so often would it not be easier just type bash to temporarily switch to a bash shell?

Easier yes, that is my current workaround. But I would prefer simple output, not simple shell. I would like to have features like autocompletion, paths without cd and other zsh + plugins goodies.

Came up with not ideal solution. It is zsh, but suggestions (not autocompletion, I mean the shadowy text from history which gets written after pressing right arrow) and other advanced things are not working. At least the item selection with arrows for autocompletion works. In .zshrc I have replaced

if [[ -e /usr/share/zsh/manjaro-zsh-prompt ]]; then


if [[ -e /usr/share/zsh/manjaro-zsh-prompt && "$DISABLE_MANJARO_PROMPT" -ne 1 ]]; then

and starting it as


I looked at manjaro-zsh-prompt, but it sources files that are way too complex for me. And I believe I shouldn’t edit them anyway (won’t updates overwrite any local changes?).

I think I saw somewhere the issue with PROMPT being ignored, I think when some shell function was defined then the shell was using just the function, not the variable, but I can’t find it now when I need it… :expressionless:

1 Like

Example, please? I have no issues copying and pasting legible terminal output with the Powerlevel10k theme. I noticed you customized it yourself in your screenshot above, so how is any of this related to Manjaro customization?


  • Don’t copy the prompt itself when copying & pasting.
  • If you want plain output for a command you aliased like replacing cat with bat, run the command with a backslash before it; i.e., \cat ....

To make BASH a little closer to what you want when you use it, install bash-completion and only store your aliases in ~/.aliases. Then source it in both ~/.bashrc & ~/.zshrc:

source $HOME/.aliases

If you don’t like the manjaro-zsh-config you can simply uninstall it. But ya, implementing a function to disable it temporarily would be interesting :thinking: