How to switch between USB wifi adapter & internal wifi adapter in laptop?

Hello everyone ,
I’ve connected an external usb wifi adapter to my manjaro-kde laptop.
but it doesn’t show in network-manager !
it worked fine in Ubuntu & Kubuntu !

Qualcomm Atheros AR9285 is the internal wifi adapter
ZyDAS ZD1211B is the external adapter


Bus 002 Device 005: ID 0ace:1215 ZyDAS ZD1211B 802.11g
Bus 001 Device 004: ID 0cf3:3005 Qualcomm Atheros Communications AR3011 Bluetooth
inxi -n                                         

           Device-2: Qualcomm Atheros AR9285 Wireless Network Adapter driver: ath9k 
           IF: wlp9s0 state: up mac: 38:59:f9:96:80:b3 
           Device-3: ZyDAS ZD1211B 802.11g type: USB driver: zd1211rw 
           IF: wlp0s29u1u2 state: down mac: aa:8a:aa:87:f2:10

I tried this …

sudo ip link set wlp0s29u1u2 up                                         
RTNETLINK answers: No such file or directory

then …

sudo modprobe wlp0s29u1u2                                  
modprobe: FATAL: Module wlp0s29u1u2 not found in directory /lib/modules/5.10.61-1-MANJARO

So what shall i do ?

Thanks in advance.

That’s the Atheros interface, not a kernel module. The ZyDAS kernel module is zd1211rw and is already loaded:

Thanks , But what should i do ?


zd1211rw is a driver for the ZyDAS ZD1211 802.11b/g USB WLAN chipset, and it is included in recent versions of the Linux kernel. See [15] for a list of supported devices. You only need to install the firmware for the device, provided by the zd1211-firmwareAUR package.

1 Like

You are a genius :smiley: , Thanks a million

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.