How to stop manjaro from muting speakers when i plug in aux microphone

i am new to manjaro so forgive me if i miss something.i bought a Aux microphone because the internal microphone is broken but whenever i plug in the microphone manjaro changes speaker port to headphones.thinking i plugged in a headphone . so every time i need to change the port
to speakers .so how do i prevent manjaro from changing speaker ports every time i plug in a microphone

have a look in pavucontrol

I have tried pavucontrol ,The ports keep changing to headphones when i unplug and plug the microphone back in or when i restart . Alsa mixer dont work either

is pipewire installed ?

pacman -Qs pipewire

yes pipewire is installed
local/pipewire 1:0.3.34-1
Low-latency audio/video router and processor
local/pipewire-media-session 1:0.3.34-1
Low-latency audio/video router and processor - Session manager

Some one please help me

I know nothing of pipewire, but lets look to see if you are running pulseaudio and pipewire

inxi -Axxx

alsa can automute current output device on detection of another output device.

execute each line of command in turn.

alsamixer # likely to show only pulseadio or maybe pipewire so...
alsamixer -c0
alsamixer -c1

alsa count devices by zero, 1,2,etc not from 1.
Even if you have only one device, alsa calls it a card

Press repeatedly to navigate to the automute section.

If its on press up or down to disable
similar to this image

Trivia for most laptops, hdmi is card 0 and analog is card 1

Laptop jack socket has an auto-mute function in ALSA. The auto-mute only detects if a jack is plugged in and cannot tell what device is connected via the jack

One way to deal with the auto-mute is to reconfigure the jack and disable the headphone connection so it only supports an external microphone

Install package alsa-tools and run the retasking tool with root privileges

sudo hdajackretask

Find the Pin ID for Headphone ; enable the Override and select Not Connected from the drop-down list

Click Install Boot Override

Reboot system to load the override

output of inxi -Axxx
Audio: Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Lenovo driver: snd_hda_intel v: kernel
bus-ID: 00:1b.0 chip-ID: 8086:1e20 class-ID: 0403
Sound Server-1: ALSA v: k5.14.0-0-MANJARO running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: yes
Sound Server-4: PipeWire v: 0.3.34 running: yes

auto-mute is disabled in alsa mixer
but when i plug and unplug my mic it still mutes my speakers
with mic plugged in

without mic plugged in

sudo alsactl store and dont work

how to install alsa-tools i cant find it

try alsa-utils

you hae both pipewire and pulseaudio running at once. Choose one not both

Pamac GUI usually shows the package as different hardware tools:

  • Echomixer (alsa-tools)
  • Envy24 (alsa-tools)
  • HDSPConf (alsa-tools)
  • HDSPMixer (alsa-tools)

or install from terminal

pamac install alsa-tools

System data is showing 2 incompatible sound servers running

Sound Server-3: PulseAudio v: 15.0 running: yes
Sound Server-4: PipeWire v: 0.3.34 running: yes

Pipewire cannot support audio unless PulseAudio is removed and replaced, but it will impede PulseAudio function

Use this command to stop, disable and mask Pipewire service and socket

systemctl --user disable --now pipewire.{socket,service} && systemctl --user mask pipewire.socket

sudo hdajackretask
Fixed my problem

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.