How to stop browser automatically launching Teams application?

To use my employer’s software stack I have installed Google Chrome and Microsoft Teams apps from the AUR.

At some point I have allowed Chrome to automatically open the Teams application when clicking on a Teams appointment link.

Now I want to undo that automatic action and I have searched high and low, but I can’t find where this setting is stored. Can someone help me? TIA!

Hi @muvvenby,

It sounds like a value was added to your mimetypes list. Please post the output of:

cat ~/.config/mimeapps.list

@muvvenby This command will do it for you :slight_smile:

sed -i '/teams/d' ~/.config/mimeapps.list
1 Like

Well now. I seem to have been 1 upped here. But yeah, should have though about it myself.

That doesn’t seem to be it…

I removed the x-scheme-handler/msteams=teams.desktop line, closed the browser, restarted the browser, but it still opens the Teams app.

I rebooted, but this line gets automatically added back after reboot and the Teams app still automatically opens.

Also, I think it is a browser permission. I clicked something like ‘always opens these links in Teams’ in the Chrome browser. When I open the meeting link in Firefox, I get the same permissions pop-up, but from Firefox. But whereas I can find the mimelist associations in the Firefox settings, I cannot seem to locate them in Chrome to reset this permission.

Maybe go to and click on the “lock” icon to reset site permissions.

Depending on your DE, you might have to check and set it there.


After some more searching and looking around, I found something that might apply. Not sure.

Open this link in Chrome:


Make sure it’s set to

Sites can ask to handle protocols

I’ll continue to look around.

Further reading:

Go to chrome://settings/clearBrowserData and clear “Cookies and other site data” of "All time.

Thanks for all the tips! Unfortunately, nothing really helps, it seems.

inxi details => Cinnamon DE
$ inxi -Fxzc0
  Kernel: 5.15.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    Desktop: Cinnamon 5.2.7 Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Dell product: XPS 13 7390 v: N/A
    serial: <superuser required>
  Mobo: Dell model: 0G2D0W v: A00 serial: <superuser required> UEFI: Dell
    v: 1.12.1 date: 12/08/2021
  ID-1: BAT0 charge: 49.3 Wh (100.0%) condition: 49.3/52.0 Wh (94.8%)
    volts: 8.7 min: 7.6 model: SMP DELL G8VCF6C status: Full
  Info: quad core model: Intel Core i7-10510U bits: 64 type: MT MCP
    arch: Comet/Whiskey Lake note: check rev: C cache: L1: 256 KiB L2: 1024 KiB
    L3: 8 MiB
  Speed (MHz): avg: 799 high: 800 min/max: 400/4900 cores: 1: 800 2: 800
    3: 800 4: 800 5: 795 6: 800 7: 800 8: 800 bogomips: 36812
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel CometLake-U GT2 [UHD Graphics] vendor: Dell driver: i915
    v: kernel bus-ID: 00:02.0
  Device-2: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 1-5:2
  Device-3: Logitech HD Pro Webcam C920 type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 5-2.3.3:6
  Display: x11 server: X.Org driver: loaded: modesetting
    resolution: 1: 1920x1080~60Hz 2: 3840x2160~60Hz 3: 1600x1200~60Hz
  OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 21.3.4
    direct render: Yes
  Device-1: Intel Comet Lake PCH-LP cAVS vendor: Dell driver: snd_hda_intel
    v: kernel bus-ID: 00:1f.3
  Device-2: Logitech HD Pro Webcam C920 type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 5-2.3.3:6
  Device-3: Realtek USB Audio type: USB driver: snd-usb-audio
    bus-ID: 5-2.3.4:7
  Sound Server-1: ALSA v: k5.15.16-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.43 running: yes
  Device-1: Intel Wi-Fi 6 AX200 vendor: Rivet Networks driver: iwlwifi
    v: kernel bus-ID: 02:00.0
  IF: wlp2s0 state: up mac: <filter>
  Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB
    driver: r8152 bus-ID: 6-2.4:4
  IF: enp62s0u2u4 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 1-7:3
  Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
  Local Storage: total: 476.94 GiB used: 372.67 GiB (78.1%)
  ID-1: /dev/nvme0n1 vendor: SK Hynix model: PC601 NVMe 512GB
    size: 476.94 GiB temp: 51.9 C
  ID-1: / size: 467.01 GiB used: 372.5 GiB (79.8%) fs: ext4 dev: /dev/dm-0
    mapped: cryptroot
  ID-2: /boot size: 968.3 MiB used: 129.6 MiB (13.4%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-3: /boot/efi size: 499 MiB used: 36.8 MiB (7.4%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-1: swap-1 type: file size: 16 GiB used: 0 KiB (0.0%) file: /swapfile
  System Temperatures: cpu: 55.0 C pch: 48.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 0 fan-2: 0
  Processes: 317 Uptime: 8m Memory: 15.33 GiB used: 6.75 GiB (44.0%)
  Init: systemd Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: 1733
  Shell: Bash v: 5.1.16 inxi: 3.3.12

I have reset the permissions on => no effect
I have deleted all cookies for all MS related domains => no effect
I have removed all protocol handlers from chrome://settings/handlers?search=protocol (Teams app wasn’t in there) => no effect
I have de-installed the Teams app, rebooted => obviously Teams can’t be started automatically now
I have re-installed the Teams app => Teams app is again automatically started when I click any Teams meeting link
So, the Teams app association is somehow preserved. I am still thinking it is the Chrome browser itself that is being stubborn about it, but I have so many logins, sessions, preferences, etc. that I don’t feel burning all that by removing/purging Chrome.

At this point I am fairly sure the setting I am trying to change is AutoLaunchProtocolsFromOrigins as described here: Chrome Enterprise Policy List & Management | Documentation

However, I have not found where I can change it. It doesn’t seem to be in the Chrome Settings and I can’t find the string anywhere in ~/.config/google-chrome.

Does it happen with a clean profile? If yes, then it is likely a system-wide setting you’ve got to look for somewhere. If no, you could always just make a new one, start afresh. Backup that config directory to test, I think:

mv ~/.config/google-chrome ~/.config/google-chrome.backup

I realise you don’t want to do this, I really do, but this might help narrow down where the issue lay, if nothing else. But sometimes you’ve got to cut your losses and go on with life. As long as you learn something from this. Even if it is just to be more careful with the mouse button.

That’s actually a great idea, thanks! :smiley: Easy to copy the settings back.

The answer is: no, it’s not a system setting, it is a browser setting. With a clean profile, when I click on the meeting link, I get the dialog that I previously agreed to.


So now we just need to convince Chrome that this setting can be changed back by me!

Here I meant all cookies not just MS related.