How to set up emby media server

Split from original topic: Folder permission on KDE

I dont know … what permissions does emby use ? is it part of some group? I couldnt find any information from their docs or ‘support’.

I suppose you could make a directory where ‘everyone’ has read/write/execute permissions, such as by using chmod 777 … but that is not really recommended.

I still think the better thing would be like this:

As to emby in general … I dont know … there are tuts out there … like this one:

on emby media website in linux arch forum the founder have post tutorial i dont can give you link here you have time check and help please

If you have a tutorial … why dont you follow it?
I have never used emby, so I doubt I bring anything extra to the table.
From what I saw it seems a pretty simple ‘start the service, navigate to localhost:8096 in your browser, and select your giant media folder’.

yes i can make this part its juste for give access to my storage

OK … so theres the Archwiki …
And it seems its user/group emby.
so … do what we did before

cd my-storage
sudo mkdir embylibrary
sudo chown emby:emby embylibrary

(note - this is all example … you can use whatever structure you want. The archwiki also seems to suggest augmenting the service so that emby user is in the shared group … and use shared group to own your desired directory [it also seems to suggest using a generic /mnt/shared directory] if you want emby to also have write and delete abilities.)

im in my-storage i dont execute mkdir embylibrary because i have make Emby folder with you when i have make my permission when i try sudo chown emby:emby Emby i recive error message invalid user

So … do you not have the service running? Its what would create the user/group.

systemctl enable emby-server --now
[zombtux@manjaro ~]$ systemctl enable emby-server --now
Created symlink /etc/systemd/system/ → /usr/lib/systemd/system/emby-server.service.
[zombtux@manjaro ~]$

ok … then how does chown go ?

same error when i type sudo chown Emby:Emby Emby

because linux is case sensitive … I didnt write Emby I wrote emby

ok if my folder is Emby with E the good command is sudo chown emby:emby Emby

yes. I dont care what the folder is called … but the user/group is specific.

ok now i dont have recive error message

So I guess I will regurgitate/simplify our steps here since we did it anyways…

sudo pacman -S emby-server
systemctl enable emby-server --now
sudo mkdir /path/to/our/new/library/on/external/partition/emby-library # 'sudo' only necessary if you do not have permissions on the external partition
sudo chown emby:emby /path/to/our/new/library/on/external/partition/emby-library

Then browse to http://localhost:8096 and set up your things.

(you’ve already done all that … so … I guess it should work now)

dont cant select my folder when i choose on localhost setup hmmm

i click on run media and when i click on zombtux dont cant

Well thats all I know.
Which … for emby … is not much.
But now, as per the thread title, you have some better understanding of permissions and further resources.

1 Like

yes thx :smiley:

Maybe it cant be behind your user owned folder … back up and place the library next to your personal one, following similar steps as above.

Or rather … wait … I see this wrong. heh.

First I think you might want to look at ‘fstab’ for automounting the partition with rights.

the hdd is mount on zombtux no ? dont cant move