How to set custom terminal size while opening script in terminal

So, I set up a keyboard shortcut that plays my favorite songs using mpv in Konsole, it works with no problems, but what I’d like for to happen is whenever opening Konsole using this command I want it to be of a specific window size so It only shows, info about the currently playing song, which I can do by manually resizing it and It does persist, but whenever I use the terminal for other things I resize it and It get’s stuck in that size and I have to resize it again, Is there a way to make it so it so whenever I use this shortcut Konsole will open in a certain window size and in other cases it will work the way it usually does?

It seems you want to send a command to the terminal emulator.
Just a quick note that the TE is itself an application, so it will take arguments as any other … but it is also specifically dependant on which TE you are using.

In the case of konsole you can probably find everything you need with:

man konsole

(also … you can set default sizing for konsole in preferences)

Assuming that you’re using Konsole ─ because you posted this in the #desktop-environments:Plasma section ─ use the --qwindowgeometry option, like so… :arrow_down:

konsole --qwindowgeometry <geometry>

… whereby you substitute <geometry> by a geometry in X11-syntax, e.g. 100x100+50+50.

For more information… :arrow_down:

konsole --help-all
1 Like

Is there a way to figure out what the geometry of a currently is?

There are two ways that I know of ─ there may be others.

1. Right-click the window title bar and choose… :arrow_down:

More Actions → Configure Special Window Settings

In the dialog window that opens, click the Detect Window Properties button. The mouse cursor will turn into a crosshair. Place this crosshair on the window whose properties you want to measure ─ in this case, the main Konsole window ─ and click. The window size and offset will now be displayed in a new dialog window.

2. Via System Settings

Workspace → Window Management → Window Behavior

  1. Click on the Movement tab. :arrow_down:

  2. Tick the checkbox for “Window geometry: Display when moving or resizing”

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.