How to safely remove Android device/USB drive?

How to safely remove (eject) Android device/USB drive?
Plasma taskbar suggests only “Mount and Open” options, no “unmount” or “eject”.
Similarly Dolphin doesn’t have the needed options.
Any way to get a visual option (without recalling terminal commands each time)?

$ inxi -S
System:    Host: roman-pc Kernel: 5.10.19-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.21.2
           Distro: Manjaro Linux

Hi, I believe if you have not yet mounted the drive, it is safe to remove.
Once you do mount the drive, you will see “safely remove” as an option.

The point is that after executing “Mount” action (or “Mount and Open” action) from respective menu - the “eject” option does not show up anywhere.


Sorry, Ive been sick. I hope you have solved your problem.
From the picture you posted, it appears you did not click on the mount option. If you do not click on mount, eject does not need to appear. You can simply remove the device.
After you click mount, thats when you device is connected to your computer, at that time you will get a “safely remove” option.

As long as mount is presented as an option you are not connected, so you can just remove the physical connection safely.

I did click the “Mount” option many times, but the “eject” option did not appear anywhere.
“I hope you have solved your problem” - nope.

I’m sorry for that! I’m by means an expert but I do use this function succesfully.
Can you post a screenshot of what you see after you click on the mount option? (The one highlighted in your second screenshot)

If you click on the browse files option, can actually see the files, and does that cause the safely remove option to appear?

Hi, I’ve had a look and what you describe indeed looks like a bug on the KDE side. Breaking it down:
1- I have tried to click “mount” as you describe, and indeed it does…nothing.
2 - Clicking “mount and open” on the left of “Android” opens Dolphin but in my /home folder.
3 - This happens when the “USB Preferences” on my phone are set to “no data transfer”.
4 - If I set the usb preference on my phone to “File transfer” then the behaviour of the “disk and devices” widget is…the same;
5 However, when “file transfer” is activated, my phone then appears in the “Devices” pan of Dolphin. Note that the phone may still appear when file transfer is disabled, but then it’s empty;
6 - It doesn’t look like the phone needs to be mounted, as I suppose it’s considered as a simple storage extension. I noticed it gets “mounted” under /mtp which probably affords it this flexibility.

In a nutshell, if you want to access your device, activate “file transfer” in the USB preferences of your phone. You don’t need to mount or unmount. The “removable devices” widget seems to have some inconsistencies / bugs in behaviours. I’m happy to investigate further etc to report the bug, but I’d need help there as I’ve never properly reported a bug.
I’ve added screenshots of the behaviour with a standard USB stick (testing 21.0 :slight_smile: )
Thanks a lot @RomanPerekhrest for highlighting this, I’m sure it will help others :slight_smile:Mount Unmount

Hi, thank you for investigating and confirming the issue.
I’m aware about “USB Preferences”: on my phone it gets enabled through “Development mode” ("USB debugging” option) - but it has no impact.
Currently, after running today’s upgrade the phone contents seems to be rendered but the “eject” option does not appear.
I’ve prepared a short demo video (gif) to show how the issue appears:

Hey, thanks for making the video, it’s helpful to see it in action. I don’t know how to flag it, but it should be safe to use in the meantime as I’ve never lost data. I’m pretty new to the forum so I’m not sure how to report bugs etc, in particular because this seems to be a KDE-related bug rather than Manjaro-specific.