How to run proton on Lutris?

So I have some wine games set up already but I think I can get more performance if I use proton, the thing is they are not on Steam, and when I chose in the Wine version any version of proton the game won’t even launch. Like I press Play button then it changes to Stop but after like 4 seconds it is changing pack to Play and literally nothing launches… And also no idea why but Proton 5.0 and Proton 5.9-GE are doubled in the list but Proton 4.2 is showing only once :woman_shrugging:

If you open up the ‘show logs’ window in lutris and try to run the game you might find some helpful error messages.
Just right-click on the game.

This error is the same for 3 games that I tested with 2 versions of Proton:

Traceback (most recent call last):
  File "/usr/share/lutris/bin/lutris-wrapper", line 16, in <module>
    from lutris.util.log import logger
  File "/usr/lib/python3.8/site-packages/lutris/util/log.py", line 9, in <module>
    from gi.repository import GLib
  File "/usr/lib/python3.8/site-packages/gi/__init__.py", line 42, in <module>
    from . import _gi
ImportError: libselinux.so.1: cannot open shared object file: No such file or directory

So I found a very similar issue on Lutris GitHub (can’t post links) and they said installing libselinux will fix it and can confirm it is now working. Also, it made new user so I need now to copy-paste from my document folders to the new user documents!

1 Like

Yes I was very hesitant to tell you to do that since libselinux was an AUR package, and I’m not sure how it’s necessary… it’s also above my pay grade of know-how.

Furthermore, I don’t have it installed and proton through lutris works fine… glad to hear it worked for you.

1 Like

FYI, Lutris natively supports the installed Proton. Under Runner options > Wine version, you can choose which version of Proton / Wine you want to use.

I’ve never needed libselinux, either.

I mean I said I was choosing it, and for some unknown reason, they were doubled like there were two Proton 5.0 and two Proton 5.9-GE. And whenever I was choosing it and starting the game it wouldn’t launch and the log said what I posted before and I literally copy-pasted the last line and found a Github issue with a solution to install libselinux and it worked for them and me.
I don’t know why it was happening but it is fixed anyways…

I was having the exact same issue and installing libselinux fixed it for me as well.

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.