How to run PoE overlay and Path of Building Community with Path of Exile Steam version

Along with Path of Exile from Steam I want to run Path of Building with Lutris and PoE overlay is on the repositories but the latter doesn’t work when I hit the hotkey in-game.

Path of Building runs with the Lutris wine version but the update fails to check. Something with SSL seems.

The binary path is on the Users\User\ Application Data folder.

I’ve never played either; however, Lutris has a forum dedicated to how to get games working on Linux either via WINE, or Steam/Proton, or other methods.

Really suggest you look there for help and answers.

I know from past they recommend you launch lutris from the console, and then collect the output when things dont work from that. Again, I really think you’ll find better help in the lutris forums.

How do I allow SSL connections to Pastebin?

Really not sure what you are asking about SSL and pastebin for, or how this is related.

I had some spare time here to look deeper for you, and found this post you made on the lutris forums with what looks like the proper solution from back in May.

By Jasoncollege24

You didn’t specify whether both items are running in the same Wine prefix. If they are, then you may need to ensure that they are both using the same version of Wine.

My suggestion is follow the suggestion above --> Use Lutris to install both the game (available separately from steam) and the overlay into the same wine context and skip the steam version. If you must interface the overlay with the steam version – look into the DXVK version launching via lutris or maybe search the lutris forums on how to interface with the wine prefex of a proton launcher.

The overlay doesn’t work when I last tried.

Path of Building runs with the Lutris wine version but the update fails to check. Something with SSL seems.

Strange, I haven’t had issues with it myself. For importing a build though, I have to change the pastebin from “https” to “http”.

That didn’t work with the community fork. As a workaround I just open the link on a browser and copy the raw data to PoB just next to the import button.

That’s not the problem here


The overlay is going to be hooking into DirectX to display over the game is my guess.
If you are playing on Linux you’re probably using the Vulkan renderer, even if you are using DirectX renderer it gets translated to vulkan or worse, opengl.

I’ve had no luck getting the overlay to work, I think that’s a fruitless endeavour unfortunately.

Path of building on the other-hand (At least the mainline version) worked perfectly with wine last I used it, including updating. It’s hard to keep track however of all the additional installed components I have for my default wine prefix., haha.

Unfortunately PoE crashes my graphics drivers when I play it so I don’t anymore. :pensive:

1 Like

This is a solution to your ssl problem. Just remove the ‘s’ from ‘https’

Tried, maybe that works for the mainline version but most of the guides are already using the community fork.

I want to try these steps done on Windows but I don’t know how to do it in Manjaro.

Try these steps.

1. Double click on the Kaspersky icon on the status bar.
2. Click on the gear icon ok the lower left to open settings.
3. Open the additional tab and click on network.
4. Scroll downwards and click on the manage exclusions option.
5. Click the add button.
6. Type pastebin dot com and click on the add button.

Check if the problem still occurs.

You’re not using kaspersky anti-virus, or even a firewall. These instructions are irrelevant.

SSL doesn’t always work with wine. I had the same problem trying to play poker… just I can’t remember what I changed.

I’m using UFW but even if I turn it off gives the error, so you are right.

Pertaining the Overlay I did the smart thing and went o Github and checked the Issues. It seems the program needs xorg-xprop and xorg-xwininfo, can’t try RN though because it’s downloading a 22GB patch.

PoB fixed itself. Steam PoE is crashing so downloading the standalone from Lutris.

I’m unsure what difference that’ll make. Did you get the overlay to work?

Overlay from repo runs but it covers the game screen with white

I dug a bit deeper and found out that it’s impossible to draw transparency without compositing in X11. Your delay fix already takes care of the issue for use with compositing. But playing with compositing in Linux introduces a noticeable performance dip. It’s not even fewer fps, it’s just delayed as compositing is trying to synchronize frames. Github issue

I wonder if I can send the app to the secondary monitor

I mean if you have two monitors… just keep open on it lmao.