How to run fSpy? it only appears the build button

I searched on the apps manager and installed the first one, but after done, it appears with the build or remove buttons, i’ve clicked the build and after finishes, look for fSpy but can’t find it, so, i’m not sure if it installed it correctly (i’m not a programmer :S)

It’s not meant to be used as a standalone application. You need to use it with another application, such as blender — there’s the blender-plugin-fspy package for that in the AUR.

1 Like

I’m sorry but it is a standalone app, and it has an addon to import the files to blender, but the first step is in the app, look:

Well, if it is a standalone app and it has a graphical user interface, then try launching it from a terminal window. If it works, then you can always create a .desktop file for it yourself and choose an icon for it.

I’m afraid that it doesn’t appear when i put this on the terminal:
ls -la /usr/share/applications

Also looked here manually in the folders and nothing:

But then, i looked for fSpy in /usr and bingo! it appeared a folder but inside lib:

What do i do with that? (i’m also newby in Linux and Manjaro) :S

Try starting it as follows… :arrow_down:


The binary is fspy in that folder /usr/lib/fspy/fspy

A desktop file don’t exist for this, however in the package there is shell script that do


exec /usr/lib/fspy/fspy

So you can simply type fspy from terminal

1 Like

Only if the shell script resides in a directory that’s in his $PATH. :wink:

OP: If the script does not reside in a directory of your $PATH, copy it to ~/.local/bin and make sure it has execute permission.

1 Like

It is installed in /usr/bin

1 Like

Another option you might want to consider is to use the AppImage that they offer.

:S it didn’t started it :S just changed to that directory i think:

I typed that before I read that there’s a script by that name in /usr/bin. So use the script and just type… :arrow_down:


… at the prompt.

1 Like

Ooohhh…that’s right! it works by typing only fspy in the terminal! :smiley:

But what if i want a button with the logo of the app in mi apps bar? can it be done? :S

For that you have to create a .desktop file. Then you can set an icon for it and add it to a panel and/or the menu.

1 Like

Awesome…but how? :S

Like any other *.desktop file …

[Desktop Entry]
Exec=fspy %F

Ooohhh…didn’t know where to put that code, but did right clic on desktop to create a txt file or something, and there it was…create a new desktop file :stuck_out_tongue: so i only copy and pasted, but then, it didn’t worked when double clicked, so then, found out that i could enable the launch option and then, it worked!! thanks a lot!! only one doubt…how can i put that desktop file on my favorites bar with all the other programs?

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.