How to revive USB stick?

After I pulled out my USB stick while some operation were still in process, it seems to be broken.

When I insert it in USB port, nothing happens.
USB port itself is fine – other USB sticks are detected as usual.

Output of lsusb before and after I insert my “broken” stick is the same. As if nothing happened.

Then I tried it on my laptop with Windows. Windows singals that some unknown USB device is connected. That’s it.

Then I came back to my PC with Manjaro.
dmesg showed me something.

This is what I see after I insert USB stick and restart dmesg command

[Сб окт 14 07:39:19 2023] usb 2-1.3: new high-speed USB device number 9 using ehci-pci
[Сб окт 14 07:39:30 2023] usb 2-1.3: device not accepting address 9, error -110
[Сб окт 14 07:39:30 2023] usb 2-1.3: new high-speed USB device number 10 using ehci-pci
[Сб окт 14 07:39:35 2023] usb 2-1.3: device descriptor read/64, error -110

What should I do to revive my USB stick?

If it is broken it is broken.

It is likely a voltage build up - when you pulled stick - which killed it.

On a small scale it is the same that happens if you pull the plug from the eletrical outlet while the vaccum cleaner is running - the flowing current creates a flash - it can be quite dangerous actually.


Replace it with a new one. I appreciate this is probably not the response you wanted. However, when this happens there is typically no cure. All I can really suggest is to never rely on a USB/flash drive for storage, unless you have some kind of redundancy; a backup, or multiple copies of the data. That said, I know this isn’t always strictly possible.

Nonetheless, the ArchWiki has a page dedicated to File Recovery, if you still think it’s worth pursuing. Cheers.

check the internet for “linux usbreset” and try to fix it with this.

Small likelihood, but maybe… Open the stick and check if the soldered connections between the actual plug and the tiny board are OK. They can get lose under mechanical strain. I was lucky a few times reflowing them even if no damage was visible.

Yes, there are low level tools to try to revive a deeply stuck usb/memory card. Sometime they work, other times don’t like what i have with a 512GB memory card that suddenly stopped working after i ran “benchmark” in gnome disks which made the program hang and card inaccessible. I tried everything on both linux and windows side to restore it, and it simply is dead.

That said, i once managed to resuscitate a memory card that was locked up on linux side using a low level program on windows. SD Memory Card Formatter for Windows/Mac | SD Association i did not try low level tools on linux side back then as i did not know about them back then.

You cannot access the memory cells if the interface to the memory cells are fried.

While there is some reason in the suggestion of cracked soldering - the chance is like a snowflake in Sahara.

That’s not a good metaphor. :mountain_snow:

1 Like

a snowflake’s chance in Hell