How to revive old system

Hi recently recieved a old pc with Manjaro 15.2 works ok but cannot update anything sudo Syy is ok but when i try Syu or Syyu it says conflicting pacman mirrors /pacman mirrorlist remove y/n this is where i am lost any help would be appreciated thank you.

There wasn’t any Manjaro 12.



So it’s no more 12 but 15.2. A 2015 Manjaro install…
I don’t know if you know what is a rolling release but, no you can’t update a 6 years old installed system. Too much has changed inbetween.

After lot and lot of work, maybe you could, with dependecies, obsolete packages, but why the hassle?

Gather the data you wish to keep (6 years old data, maybe not useful) and reinstall with the latest iso, it’s much simpler.

Even 6 months without installing Manjaro is a bit late, so 6 years…


Hi tks it is Manjaro Fluxbox 15.2 it runs very fast even without updates im pretty sur its to do with the pacman tks anyway

It will work sure, but if there are security holes in kernel or system, or issues with packages, you won’t be able to fix them.

There are too many differences/evolutions for pacman to be able to update.

Like if you wanted to update Windows XP into Windows 11.

Have you tried refreshing your mirror list?
sudo pacman-mirrors -f 5

Although, i few things to note, because of the 6-year gap:

  • if your system is 32bit, don’t bother: support for 32bit systems have been dropped
  • packages have changed format since then, so in order to update the whole system, you will need to use pacman-static for this one:
sudo pacman -Syy
sudo pacman -S pacman-static
sudo pacman-static -Syyu

Still, there is no warranty updating through this gap will work, and this may end with an unusable system. So it’s more like a free first step before reinstalling, just in case.

1 Like

First you will need to determine if it is a 32-bit or 64-bit installation as 32-bit does not exist for Manjaro.

uname -m

On a 64-bit system you will get

$ uname -m

If you are using a 64-bit system - you may succeed - but only with a lot of manual intervention - it is not recommened unless you are familiar with Arch based Linux.

The easiest method - and less error prone - is re-installing the system.

1 Like

Hi tks i have a copy now on usb flash drive so i will try your suggestions tks if all else fails i have a copy of all the programs installed may try a scripts of my own tks.

tks 64-bit yes I have a copy on flash drive so i have a live usb to try with tks.

I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.