How to revert MOZ_ENABLE_WAYLAND=1?


i wanted to get firefox to wayland because of scaling.
(sadly keepass does not work with that).
So i wanted to follow the link: Firefox - ArchWiki and put MOZ_ENABLE_WAYLAND=1 into the /usr/share/application but that did not work.

So i followed a reddit advice and used:

$ systemctl --user set-environment MOZ_ENABLE_WAYLAND=1

so as i said because of keepass i need to revert that and unset-environmet does not work :frowning:

thanks for your advice


Since it’s an environment variable, you need to set it with export in your .bashrc or bash-profile or any file where you define those variables, like that:

export MOZ_ENABLE_WAYLAND=1 # or 0 if you wanna unset it

Then log out and log back in

1 Like

…and copied and pasted the command without understanding it. Please read the Arch wiki article linked in the Reddit post. If you have questions, feel free to ask.

…the same way it was set to begin with.

systemctl --user set-environment MOZ_ENABLE_WAYLAND=0

always nice to get passive aggressive ? XD
i obviously wrote that i knew what the command did … i wanted it.
I just had unforeseen consequences. :wink:

The google said that settin git to 0 was not the way but using unset :smiley:
Obviously that is not the case here (:

Thank you for the help and support <3

I think we just had a little misunderstanding there. What is obvious to one is not always obvious to another. :wink:

Hmm, this is strange. I’m not able to set the MOZ_ENABLE_WAYLAND=1 variable at all. It used to work. :thinking:

Either way, this command should return nothing if it’s disabled:


The opposite of

systemctl --user set-environment MOZ_ENABLE_WAYLAND=1


systemctl --user unset-environment MOZ_ENABLE_WAYLAND

See man systemctl

Yes, I’m aware. He said he already tried that so I suggested changing the value to see if that worked. :wink:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.