How to restore deleted ext4 partition (not formatted)?

Hi. I made a stupid mistake deleting my relevant /home ext4 partition, thinking it was the other partition. I simply marked it for deletion during the fresh Linux install, didn’t format it. It was on HDD with MBR. Now it’s just unallocated space. Can I do something to get it back? Or at least my data.

I tried several Windows programs (I have dual-install) but they didn’t work - none of them could see the deleted partition in that unallocated space.



Try this:
But please read carefully !


If you “apply” changes, it’s just deleted. You can try with some software to try and save some data

1 Like

You can also try testdisk.


Thank you everybody. Nothing I tried helped me bring back my partition where it was. Eventually, I gave up to just restore some of the most important files I’d lost - testdisk helped with that. It’s pretty straightforward and easy to use. Except for the fact that it sets permissions of the copied files to “read only” for everybody except the owner (which you no longer are), so you have to sudo chmod -R 777 %your_data% later to access them properly.

1 Like

To avoid this happening again in the future, please read this:

(You got lucky this time around…)


1 Like

Yeah, I’ve learned this lesson (about backups) the hard way. But still, it’s a pity there’s no trivial in-system way to retrieve a lost partition when it wasn’t even formatted - simply the headers (or something) were deleted.