How to replace the default Gnome screenshot utility with flameshot?

Hello!
As the title says, I’m trying to set my default screenshot utility to flameshot but I don’t know how to do that exactly on Gnome…
I disabled the default app key and changed the default key to print screen but every time I try to take a screenshot it launches Gnome’s default app
Any help would be appreciated and thanks!

I don’t use GNOME, but you just need to find the key bind / shortcut settings in GNOME settings and change it to flameshot.

Not quite. There have been issues with using Flameshot on Gtk-based DE’s like GNOME and Cinnamon.

This is what the related keyboard shortcut options on GNOME look like:

I said that i disabled the default app keys and still launches it

The simplest workaround would be to just assign a custom shortcut for

flameshot gui

such as Alt+P

still launches default gnome app then flameshot shows and says unable to take screenshot

You can create a custom shortcut with the command :

flameshot gui -p /home/YOUR-USERNAME/Pictures

, set the shortcut to Print and save the shortcut. I tried this and it worked.

Still doesn’t work… Wouldn’t it be easier if u could remove gnome utility ??
if it’s removable

Could you please give me a screenshot of the shortcut you created?

Are you running wayland? For me Flameshot stopped working since updates in december, seems to be an issue that has not been resolved.

I get similar behaviour as you @NotLaG described above.

hah funny. I just installed Flameshot and it’s working good, i just annoyingly have to do an extra step everytime in order to take a screenshot which is sort of a hassle:

image

if i found a way to disable this and just get flameshot the “permanent” permission to access screenshots would be pretty awesome :stuck_out_tongue:
If, Bonus point, i could get a screenshot by using the screenshot key, it would be reallly awesome.

Does the Manjaro team not want to replace the default gnome screenshot utility by flameshot? It’s wayy better. I mean who takes a screenshot without annotations these days? or at least putting a red circle around the issue :wink: (OK, i just did but come on this is an exception where the whole window is the issue :wink: )

Especially people running manjaro ^^

Edit: Actually after removing the gnome screenshot utility and rebooting, now the “sharing” window does not show up anymore :slight_smile: so that’s all good, will check the “print screen button” issue later.

Hi beankylla,

In your “Edit” you say you have removed gnome screenshot, how have you done this?
I also want to disable the “sharing” windows, but I can’t find a way.

Hi,

I had just uninstalled the gnome screenshot application.

Update: Flameshot now works flawlessly without any configuration change from my side :slight_smile:

What application did you remove? what command did you use? I tried to search for “gnome screenshot” but nothing appears in the list

It is gnome-screenshot, i.e., if you want to remove it -

sudo pacman -R gnome-screenshot

I get the message: error: target not found: gnome-screenshot
Meaning that the app isn’t installed in my system when it is and I’ve never removed it

Surly there must be a way of remapping the prinscr key to another app and not just hardcoded straight to the new gnome app

The “share” screen is a quirk of xdg-desktop-portal-gnome . It affects all screenshot apps under GNOME DE.

What to do now? Install xdg-desktop-portal-gnome-noprompt-git from AUR. It reverts the “share screen” security feature in question.

What would happen next? The GNOME team is aware of the issue and the appropriate changes have been already merged. It should be fixed in the 1.15.0 release of xdg-desktop-portal-gnome

I can confirm flameshot 12.1.0-1 working as intended without “share screen” with xdg-desktop-portal-gnome-noprompt-git 42.0.1+r12+gb9850a5-1 installed on Manjaro, testing branch.

1 Like