How to redirect bass(set digital crossover)

Hi there,
Pretty big noob here(installed Manjaro couple of days ago as main) so bear with me :slight_smile:
Im using Logitech Z5500 5.1 speakers connected to onboard ALC1150. The crossover in the set was done through the control unit the speakers had, but since it burned out i had to rewire them so they would work without the head unit. And ofcourse since then the built in crossover was gone, and subwoofer wouldnt work without some additional steps.
Namely in Windows i could just enable bass redirection in the realtek driver and it would start working, same thing with a Xonar D2 sound card(here the setting was called Crossover frequency if i recall correctly).
With 2.0 and 4.0 output sub can be actually heard, but any of the .1 output settings sub goes away.

Tried few things like changing few values in /etc/pulse/daemon.conf
remixing-produce-lfe = yes
remixing-consume-lfe = yes
lfe-crossover-freq = 100

But still no cake.

Using 5.10.56-1 kernel and Manjaro 21.0.7 KDE Plasma with all latest updates

Fellow Z5500 user (and noob) here.

In that same file, is
enable-remixing = yes
I have it disabled because I donโ€™t want to have stereo content upmixed to surround. But for testing purposes I enabled it, together with both LFE settings you already enabled and the crossover freq is applied correctly.

Any change in that file requires restarting pulseaudio. So use

pulseaudio -k

in a terminal (if you are on KDE like me you can press F12 to summon one) or just reboot.

To check the active PulseAudio configuration, use this command

pulseaudio --dump-conf

enable-remixing = yes is the default setting and should not need changing

But default-sample-channels = 2 may need to be changed to default-sample-channels = 6

Use of -k or --kill option may result in pulseaudio.service becoming: inactive (dead)

But a system reboot or this command will restart PulseAudio without systemd fatality

systemctl --user restart pulseaudio

@MMMMMaett , dont want to jinx them, but after the control unit broke after only 1-2 years and i rewired them, they havent been turned off at all for probably 10 years, and still kicking :).

@nikgnomic Seems like pulseaudio isnt registering the changes for some reason.
I get this output from pulseaudio --dump-conf :

remixing-produce-lfe = no
remixing-consume-lfe = no
lfe-crossover-freq = 0
default-sample-channels = 2
default-channel-map = front-left,front-right

Even though remixing is set to โ€œyesโ€ , channels to 6, and i also added rest of speakers to channel map.
Also added this line to load-module module-combine channels=6 channel_map=front-left,front-right,rear-left,rear-right,front-center,lfe , and copied both config files to user/.config/pulse/ as i saw recommended in some other thread and did couple of restarts just in case.
Im editing the configs with kate, maybe i need to use some special tool?
Or maybe me having installed pulseaudio-modules-bt (needed aptx HD and LDAC codecs) is somehow messing with pulseaudio?

Strangest thing is that pulseaudio --dump-conf show it reads from configuration file: /home/user/.config/pulse//daemon.conf , and everything is set there correctly, but yet values differ in the dump.

Ok, i did solve my issue(after many hours of reading) but in sort of a brutish way, replaced pulseaudio with pipewire :slight_smile: .
Which in the end turned out to be a good decision, as now besides my sub working and getting the same fancy BT codecs support, i can also see the battery level of my BT receivers, and the mSBC codec is also a welcomed addition.

Thank you guys for your input on the issue, much appreciated.