How to re enable grub after restoring defaults of BIOS/UEFI?

Hi,

My laptop is a ThinkPad T14 Gen 1 (AMD).
I am dual booting Manjaro with Windows 10.

I wanted to change a setting in the BIOS, that is when I chose “Restore BIOS Defaults”. :man_facepalming:
I do not know if this is relevant, I did update the BIOS to “ThinkPad BIOS Update (Windows 10 Version 1809 or later) - 10 [64] - 1.35”
Now I do not see the grub menu anymore when starting up.
My secure boot and enhanced biometric settings are disabled.

What I have tried:

  1. Setting the “GRUB_TIMEOUT_STYLE=hidden” to “GRUB_TIMEOUT_STYLE=menu” … then changed “set timeout_style=hidden” to “set timeout_style=menu” in the /boot/grub (from windows). I cannot figure out how to update grub otherwise.

  2. in cmd : bcdedit /set {bootmgr} path \EFI\manjaro\grubx64.efi

– both did not solve the issue —

IN THEORY for a normal installation, you need to boot to a live USB of Manjaro (in UEFI mode if that is your case, which I suppose it is), and restore GRUB. Once you are on the Manjaro live USB session, open a terminal, and chroot your Manjaro installation

manjaro-chroot -a

select your installation when prompted, and then reinstall GRUB (the two commands here are for UEFI installation which I guess you have)

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck

grub-mkconfig -o /boot/grub/grub.cfg

Then exit the chroot to unmount properly your system, and reboot

exit

reboot

When rebooted, issue the following command to make sure GRUB menu entries are correct

sudo update-grub

BEWARE: you changed your GRUB config file from Windows, so now your GRUB will not be as before (but you can track what you have changed and reverse, and then issue another time the sudo update-grub command again).

Here is documentation GRUB/Restore the GRUB Bootloader - Manjaro
Maybe things could be different depending on your installation/setup of dual boot, so don’t take my explanation for granted. Not sure how you have setup your dual boot.

PS: this will happen every time you update your BIOS, it will erase some stuff in the motherboard, and will not automatically recognize a Manjaro installation so you will need to restore GRUB after BIOS update.

2 Likes

Thank you for your reply.

I had a live usb of manjaro laying around. So I booted into it.
However, I did not boot into the manjaro live but selected the “Detect EFI bootloaders” and then selected the Manjaro’s one.

I do not know what this exactly means. But I think that it is still there but needs some sort of priority change?

GRUB is still on your installation, however it is not properly written in the motherboard to be able to directly boot from the motherboard, the re-installation of GRUB just fixes that.

From the live USB you can detect the bootloader and boot your Manjaro installation, but still you will need to re-install GRUB in order for the motherboard to have the proper things written in its memory to be able to normally boot.

Ok, here is the solution that fixed it for me.

With the help of @ omano. I used a usb that has Manjaro (flashed?). From the menu I selected “Detect EFI Bootloaders”.
From there I tested the /efi/Manjaro/grubx64.efi and that worked.
So I restarted, booted into Windows and used the cmd " bcdedit /set “{bootmgr}” path \EFI\Manjaro\grubx64.efi " (so the same location).

And that fixed it.

Yeah that is what I was wondering, how was the dual boot setup, and never installed Manjaro on same disk as Windows which seems to be your case.

PS: you can now select your post as solution.

//EDIT: I did it.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.