How to properly switch from Wayland to X11 (temporarily)?


I have a two monitor setup and need to record my external screen. My setup is my laptop’s built-in 16:10 4K screen and an external Full-HD 16:9 monitor. I just installed Manjaro with Gnome and found that it’s running wayland, as simplescreenrecorder won’t work.

So, I figured that I just switch to TTY3 and run startx. But here come the problems:

  • In X11 the screen resolution for both screens are set to 2x. Therefore, the external monitor’s resolution is scaled to 948x540px which is bad :wink:
  • When I tried to open the settings app or gnome-terminal it didn’t show. After switching back to TTY2 and Wayland, I found that both programs were opened there.
  • (On the plus side: firefox and simplescreenrecorder ran properly and the screen recording of just the external monitor worked as intended)

Which is when I stopped to try it myself and figured I better ask here, how to do it properly (to not mess up the system).

  • Do I need to stop Wayland somehow or is there a possibility to log into a X11 session from GDM?
  • How do I configure fractional scaling and different scalings/screen resolutions for X11 without messing up the wayland configuration (as far as that’s possible—already read that Wayland is recommended for this kind of monitor configuration). I guess, that I can manage the configuration part, once the session runs properly—I just want to make sure that I don’t mess up the (already properly configured) wayland configuration.

You can login to an X11 session from the login screen by choosing GNOME on Xorg in the bottom right.


Thanks. I was too blind :man_facepalming:t3:

But unfortunately, I’m also not able to find the correct settings for xrandr. I played for more than an hour messing the display seetings more than once (which forced to reboot/kill x :smiley: ).

I’d appreciate it, if someone could help me figure out the correct xrandr command to have the built-in monitor at 1.5x (of it’s native 3840x2400) and the external monitor at 1x (1920x1080) at the left of the built-in monitor…

  Kernel: 5.10.63-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=b87ec433-16bf-406f-8eb6-1515bfe7e05a rw quiet udev.log_priority=3 
  Desktop: GNOME 40.4 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 40.1 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: Dell product: XPS 17 9700 v: N/A serial: <filter> 
  Chassis: type: 10 serial: <filter> 
  Mobo: Dell model: 0H7HN7 v: A00 serial: <filter> UEFI: Dell v: 1.8.2 
  date: 05/21/2021 
  ID-1: BAT0 charge: 79.1 Wh (100.0%) condition: 79.1/95.1 Wh (83.2%) 
  volts: 12.9 min: 11.4 model: SMP DELL 01RR3YM type: Li-poly serial: <filter> 
  status: Full 
  RAM: total: 15.38 GiB used: 2.97 GiB (19.3%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: 6-Core model: Intel Core i7-10750H bits: 64 type: MT MCP 
  arch: Comet Lake family: 6 model-id: A5 (165) stepping: 2 microcode: EA 
  cache: L2: 12 MiB bogomips: 62431 
  Speed: 800 MHz min/max: 800/5000 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 
  4: 800 5: 800 6: 800 7: 800 8: 800 9: 800 10: 801 11: 800 12: 800 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_capabilities 
  arch_perfmon art avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc 
  cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms 
  est f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window 
  hwp_epp hwp_notify ibpb ibrs ibrs_enhanced ida intel_pt invpcid 
  invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr mtrr 
  nonstop_tsc nopl nx ospke pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge 
  pku pln pni popcnt pse pse36 pts rdrand rdseed rdtscp rep_good sdbg sep smap 
  smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow 
  tsc tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave 
  xsavec xsaveopt xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: Dell driver: i915 
  v: kernel bus-ID: 00:02.0 chip-ID: 8086:9bc4 class-ID: 0300 
  Device-2: NVIDIA TU117M [GeForce GTX 1650 Ti Mobile] vendor: Dell 
  driver: nouveau v: kernel bus-ID: 01:00.0 chip-ID: 10de:1f95 class-ID: 0302 
  Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo 
  bus-ID: 1-5:4 chip-ID: 0c45:6a0c class-ID: 0e02 
  Display: x11 server: X.Org 1.20.13 compositor: gnome-shell driver: 
  loaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 5760x2400 s-dpi: 96 s-size: 1524x635mm (60.0x25.0") 
  s-diag: 1651mm (65") 
  Monitor-1: eDP-1 res: 3840x2400 hz: 60 dpi: 266 size: 366x229mm (14.4x9.0") 
  diag: 432mm (17") 
  Monitor-2: DP-1 res: 1920x1080 hz: 60 dpi: 102 size: 477x268mm (18.8x10.6") 
  diag: 547mm (21.5") 
  OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 21.2.1 
  direct render: Yes 
  Device-1: Intel Comet Lake PCH cAVS vendor: Dell driver: sof-audio-pci 
  alternate: snd_hda_intel,snd_soc_skl,snd_sof_pci bus-ID: 00:1f.3 
  chip-ID: 8086:06c8 class-ID: 0401 
  Sound Server-1: ALSA v: k5.10.63-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: yes 
  Sound Server-4: PipeWire v: 0.3.35 running: no 
  Device-1: Intel Comet Lake PCH CNVi WiFi vendor: Rivet Networks 
  driver: iwlwifi v: kernel port: 4000 bus-ID: 00:14.3 chip-ID: 8086:06f0 
  class-ID: 0280 
  IF: wlp0s20f3 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: dynamic noprefixroute scope: global 
  IP v6: <filter> type: dynamic noprefixroute scope: global 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8 
  bus-ID: 1-14:7 chip-ID: 8087:0026 class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends 
  Message: No logical block device data found. 
  Message: No RAID data found. 
  Local Storage: total: 982.52 GiB used: 7 GiB (0.7%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: PC611 NVMe 1TB 
  size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 type: SSD serial: <filter> rev: 11001111 temp: 38.9 C scheme: GPT 
  ID-2: /dev/sda maj-min: 8:0 type: USB vendor: SanDisk model: USB 3.2Gen1 
  size: 28.65 GiB block-size: physical: 512 B logical: 512 B type: N/A 
  serial: <filter> rev: 1.00 scheme: MBR 
  Message: No optical or floppy data found. 
  ID-1: / raw-size: 135.09 GiB size: 131.91 GiB (97.65%) used: 7 GiB (5.3%) 
  fs: ext4 dev: /dev/nvme0n1p12 maj-min: 259:12 label: N/A 
  uuid: b87ec433-16bf-406f-8eb6-1515bfe7e05a 
  ID-2: /boot/efi raw-size: 150 MiB size: 146 MiB (97.33%) 
  used: 97.2 MiB (66.5%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 
  label: ESP uuid: 9C30-A34D 
  Alert: No swap data was found. 
  ID-1: /dev/nvme0n1p10 maj-min: 259:10 size: 67 GiB fs: ext4 label: N/A 
  uuid: a0ee0cd4-6ad0-4d4e-8165-4fb037cfa184 
  ID-2: /dev/nvme0n1p11 maj-min: 259:11 size: 571.59 GiB fs: ext4 label: N/A 
  uuid: 7ad5b584-d996-4552-87d8-6e958bb9660c 
  ID-3: /dev/nvme0n1p2 maj-min: 259:2 size: 128 MiB fs: <superuser required> 
  label: N/A uuid: N/A 
  ID-4: /dev/nvme0n1p3 maj-min: 259:3 size: 71.14 GiB fs: ntfs label: OS 
  uuid: B022D3EF22D3B894 
  ID-5: /dev/nvme0n1p4 maj-min: 259:4 size: 990 MiB fs: ntfs label: WINRETOOLS 
  uuid: 66CEA5B0CEA57947 
  ID-6: /dev/nvme0n1p5 maj-min: 259:5 size: 16.41 GiB fs: ntfs label: Image 
  uuid: 109CA5DC9CA5BC9A 
  ID-7: /dev/nvme0n1p6 maj-min: 259:6 size: 1.39 GiB fs: ntfs 
  label: DELLSUPPORT uuid: 2CD2D028D2CFF45C 
  ID-8: /dev/nvme0n1p7 maj-min: 259:7 size: 50 GiB fs: ext4 label: N/A 
  uuid: 57518ac6-4cc4-4081-b9d0-b8811de94c44 
  ID-9: /dev/nvme0n1p8 maj-min: 259:8 size: 25 GiB fs: ext4 label: N/A 
  uuid: 484a7809-89fd-442b-b5fe-2274c38b3503 
  ID-10: /dev/nvme0n1p9 maj-min: 259:9 size: 15 GiB fs: ext4 label: N/A 
  uuid: 83744ab6-28d7-442c-9554-9c394711f480 
  ID-11: /dev/sda1 maj-min: 8:1 size: 2.43 GiB fs: iso9660 
  ID-12: /dev/sda2 maj-min: 8:2 size: 4 MiB fs: vfat label: MISO_EFI 
  uuid: E2C9-FF24 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 1-1:2 info: Shenzhen Goodix FingerPrint type: <vendor specific> 
  driver: N/A interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 100mA 
  chip-ID: 27c6:533c class-ID: ff00 
  Hub-2: 1-2:3 info: VIA Labs USB2.0 Hub ports: 4 rev: 2.1 speed: 480 Mb/s 
  chip-ID: 2109:2211 class-ID: 0900 
  Device-1: 1-2.2:6 info: Dell Dell DA20 Adapter type: Billboard driver: N/A 
  interfaces: 1 rev: 2.0 speed: 12 Mb/s chip-ID: 413c:b080 class-ID: 1100 
  serial: <filter> 
  Device-2: 1-5:4 info: Microdia Integrated_Webcam_HD type: Video 
  driver: uvcvideo interfaces: 4 rev: 2.0 speed: 480 Mb/s power: 500mA 
  chip-ID: 0c45:6a0c class-ID: 0e02 
  Device-3: 1-8:5 info: Ledger Nano X type: HID,Keyboard 
  driver: hid-generic,usbhid interfaces: 3 rev: 2.1 speed: 12 Mb/s 
  power: 100mA chip-ID: 2c97:4015 class-ID: 0301 serial: <filter> 
  Device-4: 1-14:7 info: Intel AX201 Bluetooth type: Bluetooth driver: btusb 
  interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0026 
  class-ID: e001 
  Hub-3: 2-0:1 info: Full speed (or root) Hub ports: 10 rev: 3.1 
  speed: 10 Gb/s chip-ID: 1d6b:0003 class-ID: 0900 
  Hub-4: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-5: 4-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Hub-6: 5-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-7: 6-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Hub-8: 6-2:2 info: VIA Labs USB3.0 Hub ports: 1 rev: 3.1 speed: 5 Gb/s 
  chip-ID: 2109:0211 class-ID: 0900 
  Device-1: 6-2.1:3 info: SanDisk Ultra Fit type: Mass Storage 
  driver: usb-storage interfaces: 1 rev: 3.2 speed: 5 Gb/s power: 896mA 
  chip-ID: 0781:5583 class-ID: 0806 serial: <filter> 
  System Temperatures: cpu: 69.0 C mobo: N/A gpu: nouveau temp: 39.0 C 
  Fan Speeds (RPM): cpu: 0 fan-2: 0 
  Processes: 305 Uptime: 3m wakeups: 495 Init: systemd v: 249 tool: systemctl 
  Compilers: gcc: 11.1.0 Packages: pacman: 993 lib: 280 Shell: Zsh v: 5.8 
  running-in: gnome-terminal inxi: 3.3.06 

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.