How to properly install epson L3150 printer/scanner?

I am trying to figure out how to set up Epson L3150.

I came from debian where I used to install something like epson-printer-escpr and then add the printer via cups or system-config-printer and it works.

I could also install the driver directly from Epson site but there is none specific to arch/manjaro linux"

I found a page aur archlinux / packages / epson-inkjet-printer-escpr but the link seems to get back to epson driver page and I have no idea how to make use of it.

For the scanner function of the printer, I have already tried simple-scan and it could find the scanner right away.

Is there any proper and clean way to do this? Please someone give some advice.

Hi @ceewanna, and welcome!

I believe the driver you are looking for, is epson-inkjet-printer-escpr:

$ pamac search epson-inkjet-printer-escpr
epson-inkjet-printer-escpr                                                                                                                                                                                                                    1.7.21-1  AUR
Epson Inkjet Printer Driver (ESC/P-R) for Linux

And that can be easily installed using:

pamac build epson-inkjet-printer-escpr

Now, I don’t know if you’ll need to reinstall for different kernels, as it’s not a dkms package, but I suspect so.

As for the scanner, it would seem you need the epsonscan2 driver from the AUR:

$ pamac build epsonscan
epsonscan2                                                                                                                                                                                                                          AUR
Epson scanner management utility

Which can be installed using:

pamac build epsonscan2

The same goes as for the printer and kernel upgrades.

Hope this helps!

Thank you for your warm welcome.
My typing of pamac search epson-inkjet-printer-escpr on terminal didn’t seem to return anything at all. However, the build command did show up a lot. That’s rather difficult for someone new to know whether pamac did find something for the search or not. What do I need to set to make it search and return something.

On scanner, I have only tried the simple scan. I used to have that epsonscan2 in debian too. The problem here again seems to come from the fact that I couldn’t get pamac to search anything.

Btw, I also tried typing epson-inkjet-printer-escpr in pamac gui and nothing found there.

I read somewhere on Manjaro official page not recommending the use of AUR so I probably won’t mess with it. Thanks for reminding me on this.

I found this.
pamac search -a escpr
epson-inkjet-printer-escpr2 1.1.52-1 AUR
Epson Inkjet Printer Driver 2 (ESC/P-R) for Linux
epson-inkjet-printer-escpr 1.7.22-1 AUR
Epson Inkjet Printer Driver (ESC/P-R) for Linux
It seems I can’t get away from AUR. But I still wonder why your typing search is different from mine that I needs to specify more options.