How to prevent system from suspend when camera is on?

How to prevent system from suspend when camera is on? I tried to use Caffeine which works great for all the apps which I know the process name. However, when I’m on the meeting via Firefox/chromium sometimes after 20 minutes my computer suspends. I use lightdm with Awesomewm.

Hello @lukastymo and welcome :slight_smile:

Do you mean it goes into deep sleep mode (S3) after 20min? Never heard, it would even do this by default… But I believe you mean the screen suspend time, then I have an idea for you:

I was also annoyed by this default 20min standby behavior when using suckless dwm, so i just created a file and increased it here:
file: /etc/X11/xorg.conf.d/99-default.conf

Section "ServerFlags"
	Option "BlankTime"	"15"
	Option "StandbyTime"	"30"
	Option "SuspendTime"	"45"
	Option "OffTime"	"60"

The numbers are minutes.

If you need it really only for the camera, then use a udev rule.


If that answer did help, please don’t forget to come back to your question after your issue has been solved and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

If it didn’t help, tell us why, please?