How to permanently disable specific Bluetooth adapter in a laptop?

I have an issue with BT adapter in my laptop where my audio just suddenly starts pausing, lagging and skipping on my TWS earbuds to a point when it just dies for 10 seconds and then comes back all laggy. I don’t know if something in Manjaro caused this or it’s hardware problem, it just happened at some point and it’s still here. It’s impossible to comfortably watch Youtube for longer than 2 minutes because of this. However, I’ve noticed that plugging in USB BT key and pairing my TWS earbuds to it and I get no pausing and skipping. However, laptop sometimes seems to fight with TWS earbuds which BT adapter to use and it’s causing problems.

I’ve tried using rfkill to disable the problematic built-in BT adapter, but it comes back on next boot causing problems again. And issue is that ID of devices seems to change every boot which is super annoying as I need to figure out which adapter is which and disable it again.

Is there any way to deal with that and permanently disable my onboard BT adapter so my USB BT adapter will be the only BT device on the laptop? I can’t physically remove the module because it’s together with WIFI adapter on same expansion card and I had no luck replacing that one. Tried with AX200 and another older Intel AC module and neither worked. So I have to stick with one that came with laptop and is causing problems.

Did you check about:

And anything more about your System?

inxi -Fanzy

I’ll check the link. It’s possible all these problems happened with transition to PipeWire as Ubuntu had BT audio problems during PipeWire transition in same way, but I couldn’t ever really verify if that was the reason or my BT adapter going bad.

Is Bluez replacement for generic BT support or just extra utility?

inxi data posted last April shows a Bluetooth device

System just freezes when entering Sleep - #3 by RejZoR

  Device-1: Realtek Bluetooth 4.2 Adapter type: USB driver: btusb v: 0.8
    bus-ID: 2-2.2:6 chip-ID: 0bda:b00a

To disable this device with a udev rule:

echo 'SUBSYSTEM=="usb", ATTRS{idVendor}=="0bda", ATTRS{idProduct}=="b00a", ATTR{authorized}="0"' | sudo tee /etc/udev.d/81-bluetooth-hci.rules

Is Bluez replacement for generic BT support or just extra utility?

Bluetooth - ArchWiki
In Linux, the canonical implementation of the Bluetooth protocol stack is BlueZ

But there are other options for Bluetooth audio:

  1. Some USB wireless headset adaptors are detected as an ALSA audio device rather than a Bluetooth device.

  2. BlueZ v5.0 dropped ALSA support for Bluetooth devices and requires PulseAudio or PipeWire,
    but AUR has bluealsa and bluez-alsa-git for ALSA support
    GitHub - arkq/bluez-alsa: Bluetooth Audio ALSA Backend

Oddly enough, I was fiddling with components and I removed some audio components and installed some extra PipeWire stuff and now audio on my TWS earbuds isn’t just skipping, pausing and dying after 5 minutes of watching Youtube video. Weird. Not sure why or how.