How to pass through usb device to virtual machine?

I am trying to install something on my phone using the manufacturer’s software, which is windows only. I installed windows 10 on virtual box and installed the software. But the software cannot find the mobile phone, which is connected via usb. Any ideas how to fix this. I also tried installing the extension pack, but that didn’t solve the issue.

You can pass through specific USB devices
or a whole port, no matter what is connected to it.
It is a setting available in the … settings menus for each VM
Can’t recall it visually right now and describe exactly where to find it.
But it is not hard to find.

Just installing the extension pack
on it’s own
won’t do the trick
(although the extension pack is needed for anything more than very basic USB 1.1 functionality - you need it to be able to use USB 2.0 and higher)

… the setting is not hard to find and even quite self explanatory when you hover the mouse over the options …


it is found at
the filters can be set with the icons on the right
you probably want the top one - matching all connected devices

I didn’t watch the video yet
choose controller type
USB Device Filters

you want the top one
not the second
… or your device has to be connected in order to be able to choose it from the menu

perhaps do not go for USB 3.0 - use USB 2.0 just to be safe

Thanks for your reply. This is what I see in the usb menu.

re-read my reply - I added to it

I recorded a video. You can see that the connected devices are not showing.

What I can see is that nothing is showing up as connected.
… not the same thing as what you said … :wink:

Is the host system picking up the connected USB device?
If the host can’t see it, it cannot pass it through to the VM.
aka: you cannot select something the host does not know about

If it is a (bricked?) phone
it’s possible that it won’t be recognized as a USB device.

Did you try and choose the first/top option?
The wildcard filter, passing through everything that is plugged into any USB port?

Perhaps you can tell what the actual problem is with the phone - and/or the model?
Perhaps there is another way … besides using the windows software that you intend to use …

The easiest thing, which you likely have eliminated as a factor spoiling your efforts, is:
make sure the cable is o.k. - try a different one …

Another idea to check for the cause is:
can you select and pass through any other device, like any USB drive you may have - just as a test … ?

Slightly ot but if you want to run phone software/usb pass through etc then ive found virt manager/qemu to be far better. I have windows 10 in virt manager and everything works, some software i just couldn’t get to run in virtual box

I used to face this problem when my user is not added to the vboxusers group.
You can add your self by running the following command:

sudo gpasswd -a `whoami` vboxusers  

# This was the origional command that I posted, but I changed it after 
# seeing usermod being used by others in the forum

# Then you must reboot…


IF that is the cause of the problem …

as almost always
the Arch wiki is helpful:

VirtualBox - ArchWiki

which links to here:

Users and groups - ArchWiki

they use this command to achieve adding the user to the group:
gpasswd -a *user* *group*

a reboot should not be necessary - just a re-login to the session or starting the app from a newly started terminal will do

Don’t you also need the Extension pack from the AUR (at same version of virtualbox) for USB passthrough to work properly?

I have never used VirtualBox without the extension pack
but it just enables USB capabilities beyond USB 1.1 (among other things).
Basic (slow) USB should still work even without it.
… and he/she has got that installed from what was told