How to open Ranger in Terminator from Dmenu?

Hi there !!
I am facing this issue of opening ranger in Terminator
I changed some configuration of ~/.local/share/applications/ranger.desktop & /usr/share/applications/ranger.desktop
to set terminal to terminator… nothing worked
Ranger is still opening in urxvt
I have no further information on how to open this thing in terminator
and my default i3-sensible-terminal is set to terminator
but lunching terminal opens up urxvt

Guys off topic I deleted the entire home folder while playing with ranger :face_exhaling:
Any suggestion in recovering it ?

What are you trying to achieve opening ranger on a hot key?
I found the command combination of

<terminal> && ranger

To work, so in your case this should look like

terminator && ranger

My own usecase was the opposite of yours as i wanted to open ranger in xterm instead of my normal terminal.


Yeah Thanks for that…I actually can do that
but I open up ranger via Dmenu…
I guess I have to change something of dmenu but don’t know what

I have one more question i.e
like first time you open up a program from dmenu you have option to choose from
Background Terminal and one more option
Can you tell me where can I go and change that ?

Easy fix here would be to edit /usr/share/applications/ranger.desktop and change the Exec line. Save and exit and now dmenu should open it in terminator.

#from this

#to this
Exec=terminator -x ranger

Navigate to the directory ~/.config/dmenu-recent/ and delete the lines that are referring to the program(s) either from the background or the terminal file in that directory.

Next time you launch dmenu you will be prompted to use background or terminal for the specific program.

IK I have mentioned that above
But nothing happened it stills lunches in urxvtc

Thanks a lot !!
worked !!

Now I have figured out that terminal is set to urxvtc
executing terminal executes urxctc
so I went to /usr/bin/terminal
and there it was


urxvtc $@
if [ $? -eq 2]; then
    urxvtd -q -o -f 
    urxvtc $@

I tried placing terminator instead of urxvtc but it didn’t work
Any idea ?

1 Like

Hi There !!
I think I found the solution
you just have to change the ~/.dmenurc or dmenu configuration file located else where
In my case it was in home folder (~/)
Replace terminal -e with terminator -x in the configuation file of dmenu
But I wanted to know how to change the default terminal to terminator instead of urxvtc

1 Like

Why not uninstall urxvt if you don’t need it. That way everything should default to just terminator.

This is exactly how to fix this.

1 Like

It’s good you found a solution, but it would have been much easier If you had asked that question in your post.

1 Like

Now another issue
I cannot find urxvtc package to remove… can you tell me what the package name is ?
because it doesn’t give me any info about the package while I do

pacman -Qs urxvtc

Its blank

It should be rxvt-unicode. If you cannot find that then remove xterm:

Goddd there are a lot of dependencies I think I would have to keep it that way…
Any other idea? Shall I pull up a new thread for that ?

You can but first try methods listed here:


Thanks !!

One simple method:
My terminal: /usr/bin/terminator

First: sudo mv /usr/bin/terminal /usr/bin/terminal.bak
Then: sudo ln /usr/bin/terminator /usr/bin/terminal

That’s all!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.