How to open Filezilla files in Kate?

Hello everyone, I once did it successfully, but now I can’t understand how. I want the file to be edited in Kate on the server when FileZilla is connected, for this I prescribed using the following editor


The default file associations are empty, I didn’t touch anything, I tried to write something like this

txt /usr/bin/kate
txt "/usr/bin/kate"
php /usr/bin/kate
. /usr/bin/kate

Doesn’t do anything, opens an office in LibreOffice by default. Tell me, who knows how to make it edit in Kate?) Thanks

For file extensions in general for KDE.
System Settings > Applications > File Associations
Search for *.txt and make sure Kate is added and as first choice.

If that does not work, it’s something YOU have changed inside Filezilla.

I just tried with Filezilla and it works. Rightclick file > open > opens in Kate.

I have not changed anything so I guess this is default and works for me:

Filetype associations is empty like yours.

Thanks to yours, and my next digging, this is what I did, launched Filezilla again, and went into the default editor settings and saw where it got Libreoffice from, installed Kate in the same way


It automatically installed this in the associations, I believe it will continue to register as files are opened

log /usr/bin/kate

Everything worked out! Thank you!
I’m deleting the photo due to the load on the forum, this is how I wrote my article, and if anyone gets lost it will be really useful

Please remove all those pictures (in your last post), they are of no use and is only a strain on the forum.

An easier way to change associations is to right click the file, select properties and then change the Open with applications, you can reorder them or add new associations.

1 Like

Mmm Three left over I find very useful when I forget again how I did it)

Perhaps they are best kept with your personal notes. I doubt they will be allowed to remain in this thread for very long. Images are generally discouraged as they can become a drain on site resources after a time. Cheers.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.