How to make the terminal not use special font characters?

The terminal by default seems to be using special characters that exist only in some special fonts. So, when I connect to Manjaro using SSH, it shows rectangles for those characters. I could change the font of the SSH to a special font, but I have to download such font, install it, and change the setting on each client computer. This is tiresome. If I can set Manjaro not to use special characters in the first place, I would not have to do those on the clients.

Is there a quick setting to make Manjaro not to use special characters? Like some sort of preset?


Open settings, go to “Manage Profiles…” create a new profile (don’t change anything, just click “New” and then “Ok”) and set it as the default. It should solve your problem.

I have no idea why they changed the terminal emulator to have those lame fonts in the first place, the default profile from Manjaro is also broken because some commands don’t even work on it. Changing it to a fresh profile should solve most of these issues.

You can disable the powerline prompt by changing your ~/.zshrc

# Use powerline

I think that you might misunderstood my question. The client from which I connect to Manjaro is Windows (more specifically the app is Windows Terminal), so instead of changing Windows computers’ settings, I want to change Manjaro so that it would send only normal characters to SSH clients, just like Ubuntu.

Oh even easier! I had to do this because of the terminal app I use on my iPhone can’t handle nerdfonts as well.

I added to my ~/.zshrc the following:

if [[ -n $SSH_CONNECTION ]]; then

I tried disabling it, and it worked but it disabled the elapsed time display. So, it is all or nothing? There is not a way to keep the features but just use normal characters instead of special characters that only exists in special fonts?

It is part of the powerlevel10k theme. You can mess wth the prompt using p10k configure.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.